LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-19-2008, 06:17 PM   #1
wcnghj
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Rep: Reputation: 0
Problem with proftpd


I seem to be having some trouble getting logged in trough ftp. My server is located in my house. I am 100% sure the password I am entering is correct. I am also commented out the user 'root'(one I am trying to login to ftp with) in the config file.

Code:
[18:11:53] SmartFTP v2.5.1008.27
[18:11:53] Resolving host name "192.168.2.5"
[18:11:53] Connecting to 192.168.2.5 Port: 21
[18:11:53] Connected to 192.168.2.5.
[18:11:58] 220 ProFTPD 1.3.0 Server (ProFTPD) [192.168.2.5]
[18:11:58] USER root
[18:11:58] 331 Password required for root.
[18:11:58] PASS (hidden)
[18:11:58] 530 Login incorrect.
If anyone can help, that would be great

Last edited by wcnghj; 01-19-2008 at 06:19 PM.
 
Old 01-19-2008, 07:16 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
Is this the part you uncommented;
Code:
# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
#DefaultRoot ~
also this may help;
http://www.proftpd.org/localsite/Use...nked/x258.html

Last edited by comprookie2000; 01-19-2008 at 07:19 PM.
 
Old 01-19-2008, 07:38 PM   #3
wcnghj
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Original Poster
Rep: Reputation: 0
No, I made it so the root could be used as ftp.
Code:
#
# To have more informations about Proftpd configuration
# look at : http://www.proftpd.org/
#

# This is a basic ProFTPD configuration file (rename it to 
# 'proftpd.conf' for actual use.  It establishes a single server
# and a single anonymous login.  It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName			"ProFTPD"
#ServerType			standalone
ServerType inetd
DefaultServer			on
<Global>
DefaultRoot	~		psacln
AllowOverwrite		on
RootLogin on
AllowStoreRestart on
AuthAliasOnly off
</Global>
DefaultTransferMode	binary
UseFtpUsers			on

# Port 21 is the standard FTP port.
Port				21
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask				022

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances 30

#Following part of this config file were generate by PSA automatically
#Any changes in this part will be overwritten by next manipulation 
#with Anonymous FTP feature in PSA control panel.

#Include directive should point to place where FTP Virtual Hosts configurations
#preserved

ScoreboardFile /var/run/proftpd/scoreboard

# Primary log file mest be outside of system logrotate province

TransferLog /usr/local/psa/var/log/xferlog

#Change default group for new files and directories in vhosts dir to psacln

<Directory /var/www/vhosts>
	GroupOwner	psacln
</Directory>

# Enable PAM authentication
AuthPAM on
AuthPAMConfig proftpd

IdentLookups off 
UseReverseDNS off

AuthGroupFile	/etc/group

Include /etc/proftpd.include
Quote:
Originally Posted by comprookie2000 View Post
Is this the part you uncommented;
Code:
# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
#DefaultRoot ~
also this may help;
http://www.proftpd.org/localsite/Use...nked/x258.html

Last edited by wcnghj; 01-19-2008 at 07:40 PM.
 
Old 01-19-2008, 07:58 PM   #4
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
What distro?
You don't want to run the chroot do you so comment that line;
#DefaultRoot ~
then restart it
I don't use proftpd, I use Pure-FTPd so I am just guessing
do you have the file /etc/pam.d/ftp
 
Old 01-19-2008, 08:06 PM   #5
wcnghj
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Can you tell me hoe to uninstall this and install Pure-FTPd?

I have CentOS.
 
Old 01-19-2008, 08:17 PM   #6
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
You should be able to get it to work, you just have to spend a little time;
This is for redhat 4 about the same as centos
See if you missed something;
I would start at the PAM part
Just make sure you restart it each time you edit the conf file
http://cosi.clarkson.edu/docs/faq/proftpd.html

Last edited by comprookie2000; 01-19-2008 at 08:19 PM.
 
Old 01-20-2008, 08:37 AM   #7
wcnghj
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks, turns out plesk got installed and was screwing things up. Thanks for your help.roblem is fixed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
having problem with proftpd noorudin Linux - Software 1 06-21-2006 01:56 AM
proftpd problem hnad Slackware 5 10-08-2004 02:49 AM
Disabling the chroot in proftpd and enabling root logins on ssh/proftpd jon_k Linux - Software 1 06-16-2004 11:27 AM
proftpd problem freelinuxcpp Linux - Networking 2 11-05-2003 09:07 AM
HELP!!! proftpd problem jester13rok Linux - Networking 4 03-20-2002 05:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration