LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-28-2007, 10:25 PM   #1
Griefond
LQ Newbie
 
Registered: Aug 2007
Posts: 8

Rep: Reputation: 0
Problem with mandriva one


Hi guys, I get some troubles when trying to:
1. login as root in graphic mode (x windows). A message box "root login is not allowed" appeared. What should I do?
2. My flashdisk is not detected. (Adata PD2 /Myflash)
3. All device are read only. I've try 'chmod 777 /mnt/hda1'. But it's failed

Thank you for your answers

Last edited by Griefond; 08-28-2007 at 10:29 PM.
 
Old 08-29-2007, 08:12 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi Griefond, Welcome to lq. First, you don't need or want to run the gui as root, you would be better served to create a user account and su to root for tasks that require it. KDE even warns against this here.

http://docs.kde.org/userguide/root.html

If you've skipped adding a user account during installation try
Code:
man useradd
to see about creating one.

Second, do you mean a usb drive when you say flashdisk? If so, have a look with fdisk.

Code:
fdisk -l
You'll likely be looking for something like /dev/sda.

Third, Once you get the first two issues worked out you shouldn't have any problems with device permissions unless you've messed them up with chmod. There is a great guide that will help you get through the learning curve here.

http://linux-newbie.dotsrc.org/

I hope some of this helps.
Good luck. ;-)
 
Old 08-30-2007, 01:19 AM   #3
Griefond
LQ Newbie
 
Registered: Aug 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Thank you for your answers, Peacedog.
It's seems reasonable why we don't need to login as root in KDE
But I still don't understand how to use KDE su.
When I try to press alt+F2, I don't get anything except black screen with console mode...
Altough I turn into 'root' in console mode, Still I can't use this command:
cp /home/music/*.mp3 /mnt/sda1
(My USB flashdisk is mounted in mnt/sda1)

What should I do?

NB: I'm sorry, I'm not a good english speaker,... that's why my threads looks 'strange'

Last edited by Griefond; 08-30-2007 at 01:20 AM.
 
Old 08-30-2007, 08:17 AM   #4
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Have you been able to login to the GUI with your user? Is your user name music? What are the permissions on the usb drive? If your logged in to the GUI as your user then open a terminal (Konsole) and su to root if you need it.
Good luck. ;-)
 
Old 09-05-2007, 10:50 PM   #5
Griefond
LQ Newbie
 
Registered: Aug 2007
Posts: 8

Original Poster
Rep: Reputation: 0
I've been able to login as my user,.... it's very easy,.....
I also have been able to login as root in console (terminal) mode
But, I still can't play music,... or do a lot of thing in non graphical mode.

That's why I want to become root in graphical mode,...

My user name is not a name of music. I just want to copy some mp3 file from my home directory to my USB flashdisk. Sorry I should write
'cp /home/Griefond/music/*.mp3 /mnt/sda1'. My user name is my nick here,... Griefond

The owner of USB device is root,... So that I can't access it except I'm the root,.... (I can access my flashdisk only in console mode by using 'su')

I can copy some files from my flashdisk but
I can't copy any files to my flashdisk

It's my prime problem

By the way,... what linux distribution do you use?

Last edited by Griefond; 09-05-2007 at 10:55 PM.
 
Old 09-05-2007, 11:00 PM   #6
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
/home/music means your user is music, once your files are copied to your home directory go into KDE and play them
 
Old 09-06-2007, 08:01 AM   #7
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Quote:
Originally Posted by Griefond View Post
I've been able to login as my user,.... it's very easy,.....
I also have been able to login as root in console (terminal) mode
But, I still can't play music,... or do a lot of thing in non graphical mode.

That's why I want to become root in graphical mode,...
If you're logged into the GUI as your user and you can't play music it's likely a permission problem, if you can't play music at all you've likely not setup your sound card properly. Try running alsamixer and unmute your volume channels.

Quote:
My user name is not a name of music. I just want to copy some mp3 file from my home directory to my USB flashdisk. Sorry I should write
'cp /home/Griefond/music/*.mp3 /mnt/sda1'. My user name is my nick here,... Griefond

The owner of USB device is root,... So that I can't access it except I'm the root,.... (I can access my flashdisk only in console mode by using 'su')

I can copy some files from my flashdisk but
I can't copy any files to my flashdisk

It's my prime problem
You probably mounted the device as root. I'm not sure how your install is setup, so try adding this line to your /etc/fstab file.

Code:
/dev/sda1 /mnt/sda1 vfat user,noauto,umask=0   0 0
With that line you should be able to mount the device as your user which should solve any permission problems.


Quote:
By the way,... what linux distribution do you use?
Currently Slack, OpenBsd, FreeBsd, in the past, I've tried most of the major players, Redhat, Mandrake, Suse, Gentoo, Debian, etc. Hope this helps.
Good luck. ;-)
 
Old 09-10-2007, 09:33 PM   #8
Griefond
LQ Newbie
 
Registered: Aug 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
If you're logged into the GUI as your user and you can't play music it's likely a permission problem, if you can't play music at all you've likely not setup your sound card properly. Try running alsamixer and unmute your volume channels.
You're right,... it's permission problem.
I've try chmod 777 and it's work,... Thank you,....

Quote:
You probably mounted the device as root. I'm not sure how your install is setup, so try adding this line to your /etc/fstab file.

Code:

/dev/sda1 /mnt/sda1 vfat user,noauto,umask=0 0 0

With that line you should be able to mount the device as your user which should solve any permission problems.
I've tried to add
/dev/sda1 /mnt/sda1 vfat user,noauto,umask=0 0 0
to /etc/fstab
But it's doesn't work,...
I've tried to change vfat into auto,... but it doesn't work either,....
No idea,... what should I do....

A lot of thanks after all
 
Old 09-11-2007, 01:33 AM   #9
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Putting "/dev/sda1" in your fstab isn't really a good idea IMO, as you generally can't be certain that your device will always be /dev/sda (unless of course you can be certain!). You should look into making a udev rule for it.

Anyway, you need to say what "doesn't work" actually means. Do you get error messages? Post them..
 
Old 09-11-2007, 01:32 PM   #10
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Quote:
I've tried to add
/dev/sda1 /mnt/sda1 vfat user,noauto,umask=0 0 0
to /etc/fstab
But it's doesn't work,...
I've tried to change vfat into auto,... but it doesn't work either,....
No idea,... what should I do....
You're probably trying to mount it via the command line, I was in process of helping you set it up from the GUI since you seem to want to do most things in that interface. Running KDE logged in as user with that line in your fstab and the stick plugged in, right click on your desktop and choose Link to new hard disk. That should give you a selection list of your fstab devices from there choose the usb stick. You should now have an icon on the desktop which you can right click on and mount/unmount your stick.

As the previous poster stated you should look into udev, what I've offered is kind of a band-aid fix.
Good luck. ;-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva sound problem, need help! EYEdROP Linux - Software 16 03-04-2007 09:43 PM
Problem with Mandriva =/ ompus Mandriva 11 01-16-2007 05:25 AM
one problem in mandriva abhijeetnayak Mandriva 5 06-10-2006 11:40 AM
Installation Problem w/ Mandriva 10.2 Cupps Mandriva 1 05-04-2005 04:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration