LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-16-2017, 07:11 AM   #1
cls567
LQ Newbie
 
Registered: Apr 2017
Posts: 6

Rep: Reputation: Disabled
Problem with language settings


Hello! Some text in menus appear in something that looks like Russian, not sure about that. Nautilus File Manager for example, some menus in Yast as well. I'm using Gecko Linux, rolling release. Any way to correct this?
 
Old 04-17-2017, 04:24 AM   #2
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19.1 MATE
Posts: 8,016
Blog Entries: 5

Rep: Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859
Hi, cls567, and welcome to LQ.

Can you please paste the output from the locale command.

Also, can you let us know which distro (and version) and desktop environment you are using.
 
Old 04-17-2017, 05:40 AM   #3
cls567
LQ Newbie
 
Registered: Apr 2017
Posts: 6

Original Poster
Rep: Reputation: Disabled
Hi! I use Gecko Linux, xfce, and it's the rolling release

locale
LANG=sv_SE.utf8
LC_CTYPE=sv_SE.utf8
LC_NUMERIC=sv_SE.utf8
LC_TIME=sv_SE.utf8
LC_COLLATE="sv_SE.utf8"
LC_MONETARY=sv_SE.utf8
LC_MESSAGES="sv_SE.utf8"
LC_PAPER=sv_SE.utf8
LC_NAME=sv_SE.utf8
LC_ADDRESS=sv_SE.utf8
LC_TELEPHONE=sv_SE.utf8
LC_MEASUREMENT=sv_SE.utf8
LC_IDENTIFICATION=sv_SE.utf8
LC_ALL=
 
Old 04-17-2017, 05:42 PM   #4
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19.1 MATE
Posts: 8,016
Blog Entries: 5

Rep: Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859Reputation: 2859
Quote:
Originally Posted by cls567 View Post
Hi! I use Gecko Linux, xfce, and it's the rolling release

locale
LANG=sv_SE.utf8
LC_CTYPE=sv_SE.utf8
LC_NUMERIC=sv_SE.utf8
LC_TIME=sv_SE.utf8
LC_COLLATE="sv_SE.utf8"
LC_MONETARY=sv_SE.utf8
LC_MESSAGES="sv_SE.utf8"
LC_PAPER=sv_SE.utf8
LC_NAME=sv_SE.utf8
LC_ADDRESS=sv_SE.utf8
LC_TELEPHONE=sv_SE.utf8
LC_MEASUREMENT=sv_SE.utf8
LC_IDENTIFICATION=sv_SE.utf8
LC_ALL=
Thanks. What I would suggest is that you edit /etc/default/locale to set/add LANGUAGE="sv:en", save the file, log out and log back in again.

I'm not quite sure what's going on but I think the system may be resorting to the Cyrillic language, probably Russian, as a fall-back if it's not finding the Swedish strings for a given text. The above will tell the system to fall back to English.

Last edited by hydrurga; 04-17-2017 at 05:43 PM.
 
Old 04-19-2017, 12:15 PM   #5
cls567
LQ Newbie
 
Registered: Apr 2017
Posts: 6

Original Poster
Rep: Reputation: Disabled
OK! Thanks! I will try that out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] [Mint 15 Cinnamon][ Clock language settings problem DeeGee Linux Mint 1 07-01-2013 10:35 PM
[SOLVED] language settings jheengut Linux - Desktop 6 11-09-2012 11:57 AM
Mepis language settings cosm MEPIS 1 11-01-2006 10:26 AM
Is there any way to change the Language settings? Arpad Linux - Newbie 1 03-04-2004 04:05 PM
Language settings in GNOME Aldebaran Linux - Newbie 4 08-16-2003 06:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration