LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-25-2011, 07:59 AM   #1
benj1996
LQ Newbie
 
Registered: Sep 2011
Posts: 4

Rep: Reputation: Disabled
Problem with installing webmin on dsl-4.4.10


Hello,

I have running damn small linux 4.4.10 on an Thin Client. The first problem with the automaticly starting of the ssh daemon is now solved. But I have the problem, that i can't install Webmin. I have downloaded the dpkg extension for damn small linux but i get errors, wenn i install the debian Webmin.

This was the errors:
Code:
dsl@0[dsl]$ sudo dpkg --install webmin.deb
dpkg: regarding webmin.deb containing webmin, pre-dependency problem:
 webmin pre-depends on perl
  perl is not installed.
dpkg: error processing webmin.deb (--install):
 pre-dependency problem - not installing webmin
Errors were encountered while processing:
 webmin.deb
Then I have try to install perl but then i get another errors:
Code:
sudo apt-get install perl
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  perl: Depends: perl-base (= 5.6.1-8.9) but 5.8.0-18 is to be installed
E: Broken packages
Sorry for my bad english then i was from switzerland.

Thank you for the help!

Benj

Last edited by benj1996; 09-25-2011 at 08:01 AM.
 
Old 09-26-2011, 04:57 PM   #2
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,257

Rep: Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202
Welcome to the forums Benj, your English is fine!

DSL is an old, outdated, dead project... I highly recommend installing a modern, supported distro such as as Debian, Slackware, Ubuntu, TinyCore, etc.

The error in this case is likely because the package webmin.deb that you are trying to manually install was not designed for DSL 4.4.10. Its "dependencies" are not being satisfied (wrong version of perl). I do not know how to resolve this error because DSL is out of support.
 
1 members found this post helpful.
Old 09-26-2011, 05:13 PM   #3
benj1996
LQ Newbie
 
Registered: Sep 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hi Snowpine,

Thank you, it's only School english

I use DSL then it was running perfectly on my Thin Client. The problem was, the Thin Client has no strong hardware. I've downloading now Debian. I hate my slow Connection ^^. I hope that Debian was running on the Thin Client. When Debian didn't run on the Thin Client, then i was testing slackware.

Thank you for your help, snowpine.


Benj
 
Old 09-26-2011, 05:19 PM   #4
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,257

Rep: Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202
For what it's worth, I found some topics on the DSL forums:

http://www.damnsmalllinux.org/f/topic-3-14-19509-0.html
http://www.damnsmalllinux.org/f/topic-3-9-18824-0.html

etc.
 
1 members found this post helpful.
Old 09-26-2011, 05:25 PM   #5
benj1996
LQ Newbie
 
Registered: Sep 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Ok, when debian and slackware don't run on the system then i try this Yeah it was durin 5minutes and then was the download of debian finished ^^.

Thank you for your help. You are welcome.

Benj
 
Old 09-26-2011, 05:29 PM   #6
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,257

Rep: Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202Reputation: 1202
You're welcome and good luck!
 
Old 09-28-2011, 12:56 PM   #7
benj1996
LQ Newbie
 
Registered: Sep 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hello,

Sorry for the late Reply. I've now returnt to Damn Small Linux. It was running as the best on the thin client. The other distributions dosn't run on the Thin Client. I think the i586 architectur ist the Problem. But hey, i can life without webmin. While the SSH Server and File Server running ist the most good ^^

I thank you anyway for the help!

Benj
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing Wine in DSL 4.4.10 stevepohler DamnSmallLinux 1 01-06-2009 06:13 PM
Problem installing and using Webmin Morrac Linux - Software 2 03-12-2008 12:36 AM
Simple Problem Installing DSL RAdams DamnSmallLinux 7 08-31-2006 04:50 PM
problem Installing webmin computerfineman Linux - Networking 10 07-17-2005 04:40 PM
errors installing webmin due to gnome screen problem? Moebius Debian 1 10-03-2004 08:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration