LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problem with ia32-libs (https://www.linuxquestions.org/questions/linux-newbie-8/problem-with-ia32-libs-4175605705/)

riscv 05-11-2017 07:57 AM

Problem with ia32-libs
 
Hello,

Does anyone know why I can't install ia32-libs ? (Ubuntu 14.04 virtualbox)

Code:

root@alpha-VirtualBox:/home/alpha# sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree     
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0

E: Package 'ia32-libs' has no installation candidate

Thank you

Habitual 05-11-2017 09:43 AM

Quote:

Originally Posted by riscv (Post 5709071)
Hello,

Does anyone know why I can't install ia32-libs ? (Ubuntu 14.04 virtualbox)

Code:

root@alpha-VirtualBox:/home/alpha# sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree     
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0

E: Package 'ia32-libs' has no installation candidate

Thank you

I'll bite,
Quote:

Originally Posted by riscv (Post 5709071)
Code:

Package ia32-libs is not available

That package, from experience, I only saw it used for Skype from Ubuntu repo
Now that Skype has changed its client recently, here is what I see and expect
Code:

apt-cache policy ia32-libs skype
ia32-libs:
  Installed: (none)
  Candidate: (none)
  Version table:
N: Unable to locate package skype

Why do you need the ia32-libs package and is one of the suggested packages going to work?
Is this Skype, or not-Skype-related?

Just sayin'

riscv 05-11-2017 09:57 AM

It's not Skype-related. It's actually for the xilinx tools and arm-xilinx-linux-gnueabi in here.

ondoho 05-11-2017 01:39 PM

are you running 14.10 (from your other thread) AND 14.04 (from this thread) in 2 seperate virtual machines???

hydrurga 05-11-2017 01:54 PM

Quote:

Originally Posted by riscv (Post 5709133)
It's not Skype-related. It's actually for the xilinx tools and arm-xilinx-linux-gnueabi in here.

The instructions that you link to only suggest the installation of ia32-libs for Ubuntu 12.04. You're running Ubuntu 14.04.

Did you try installing the Xilinx tools without first attempting to install ia32-libs?

riscv 05-11-2017 08:36 PM

ondoho I'm sorry, I forgot that I had downgraded from 14.10 recently. I'm on 14.04 now, I edited the other thread. Thank you.

riscv 05-11-2017 08:43 PM

hydrurga I had only installed Vivado and SDK (2015.4). It opens the program and reads the bitstream. But I haven't done anything further than that: Such as Uboot and Linux kernel etc ...

I tired to build the host software without installing ia32-libs, I got an error: arm-xilinx-linux-gnueabi-gcc: not found.
If it helps, here's the context.


All times are GMT -5. The time now is 08:44 PM.