LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-22-2005, 09:55 AM   #1
ned99
Member
 
Registered: Oct 2005
Location: Peterborough, Ontario
Distribution: Ubuntu
Posts: 30

Rep: Reputation: 15
Problem with Fluxbox .xsession file.


Hello.

I have a quick question about Fluxbox. In order to get gkrellm to start automatically in the Slit I created a .xsession file in my home directory with the following lines:

gkrellm -w &
fluxbox

This works fine and gkrellm starts without any problems, however when I go to menu -> exit to quit fluxbox and return to the command prompt gkrellm won't shutdown and fluxbox hangs. I can quit by hitting Ctrl + Alt + Bksp a couple of times however it's annoying and I was hoping there's a command I could add to the .xsession file to shutdown gkrellm when I exit fluxbox.

Thanks.
 
Old 10-22-2005, 11:46 AM   #2
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,178

Rep: Reputation: 47
Try putting the gkrellm command in ~/.xinitrc instead. So the file would look like this:

gkrellm -w &
startfluxbox
 
Old 10-22-2005, 02:35 PM   #3
Netizen
Member
 
Registered: Sep 2003
Location: Texas
Distribution: Slackware and Ubuntu
Posts: 355

Rep: Reputation: 30
Or try putting it in ~/.fluxbox/apps like the fluxbox FAQ explains..

http://fluxbox.sourceforge.net/docs/...ev.php#startup
 
Old 10-22-2005, 04:12 PM   #4
ned99
Member
 
Registered: Oct 2005
Location: Peterborough, Ontario
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
I was thinking about doing that however neither of those files exits in my home directory. Can I just create them like I did with the .xsession file?

Update: I've tried creating both of those files (apps and .xintirc) with the gkrellm start line but it doesn't work. I've also tried adding those lines to the .xinitrc file in /etc/X11/xinit as root but that did nothing either. So far the only thing that has worked is to create the .xsession file in my home directory with those lines. Any idea why I don't have an apps or .xintirc file in my home directory as everything I've read about Fluxbox seems to indicate that I should. (I've got view hidden files enabled in Xfe btw)

Last edited by ned99; 10-22-2005 at 04:30 PM.
 
Old 10-22-2005, 08:01 PM   #5
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
The apps file should be in ~/.fluxbox/.
 
Old 10-22-2005, 10:00 PM   #6
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
i think .xsession is for when you use a session managers
it will still work if you use startx if it gets called

if you use startx you really have to read it and follow the trail of scripts to see exactly whats happening
if you are going to use .xinitrc a good idea is to
cp /etc/X11/xinit/xinitrc /home/<username>/.xinitrc

and alter it from there
Code:
 gkrellm -w &
 startfluxbox
also
mv .xsession .xsessionBK
so that's not in the way
because xinitrc or some other script is calling .xsession and causing startus uppus interuptus (Latin computer terms)


x dies on whatever it was started on using exec
in startfluxbox script thats
exec ~/.fluxbox/startup
that then calls
exec /usr/bin/fluxbox

if you want to do it on your own with .xsession just use
exec /usr/bin/fluxbox
instead of just fluxbox like you have and it might work just fine

Last edited by foo_bar_foo; 10-22-2005 at 10:01 PM.
 
Old 10-23-2005, 10:58 AM   #7
ned99
Member
 
Registered: Oct 2005
Location: Peterborough, Ontario
Distribution: Ubuntu
Posts: 30

Original Poster
Rep: Reputation: 15
Thank you all very much. Adding exec /usr/bin/fluxbox to my .xsession file solved the problem. I still don't have an apps file in ~/.fluxbox though, weird. Anyway thank you again.
 
Old 10-23-2005, 01:40 PM   #8
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Rep: Reputation: 30
Do you have a devel or stable version of Fluxbox? I believe only the devel versions have the apps file with all its functionality. It's not a good naming system, though, since the devel versions are just as stable as what most other people call "stable," the way I understand it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Erased my .xsession file Little Dump Linux - Newbie 5 12-10-2008 11:49 PM
No .xsession file lantern Debian 2 01-21-2005 05:41 PM
login from KDM to fluxbox with rox --pinboard after editing .xsession esteeven Linux - General 1 08-02-2004 04:20 PM
.xinitrc/.xsession - Where are they? Fluxbox the_rydster Slackware 3 03-07-2004 01:45 PM
can't run .xsession file evian Linux - General 4 09-25-2003 06:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration