LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-13-2005, 06:16 PM   #1
nanjil
Member
 
Registered: Jul 2005
Posts: 70

Rep: Reputation: 15
problem with computer name


whe i first get into my system the name of the system always shows up as local host.
I tried modifying r.sysinit to include howtname -F <file_with_computer_name>

but even after this the name still shows up as localhost.

I had to manually run the hostname to force the computer name.

This also confuses samba server which comes on at bootup.
I found that afte i force the host name , if i stop and restart the samba server it gets the correct name and the windows machines are then able to access the linux machine.

is there any way I can force my computer name during early boot up?

thanx
 
Old 08-13-2005, 08:23 PM   #2
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
If you had named the system initially with a unique name and wanted to change it, then you could just search for all occurrences of the name in /etc and modify any file containing the name, unless you named it something like “local”.

Unfortunately, there are lots of “localhost” occurrences in /etc that should not be changed, so you cannot blindly go through and substitute the new name for localhost.
 
Old 08-14-2005, 08:11 AM   #3
Ynot Irucrem
Member
 
Registered: Apr 2005
Location: Perth, Western Australia
Distribution: Debian
Posts: 233

Rep: Reputation: 30
I've done this a couple of times simply running "hostname wardlemonger-2" and adding a line like this to my /etc/hosts
Code:
127.0.0.1         wardlemonger-2 wardlemonger-2.WORKGROUP
where wardlemonger-2 is the new hostname you want, and WORKGROUP is the samba workgroup.
 
Old 08-14-2005, 12:04 PM   #4
nanjil
Member
 
Registered: Jul 2005
Posts: 70

Original Poster
Rep: Reputation: 15
modification of /etc/hosts did not help. It seemed to be getting eh name localhost form somewhere. I am running mandrake 10.2

only gnome complained something about not getting localhost
 
Old 08-15-2005, 08:50 AM   #5
Ynot Irucrem
Member
 
Registered: Apr 2005
Location: Perth, Western Australia
Distribution: Debian
Posts: 233

Rep: Reputation: 30
found this by googling "how to change hostname linux". hope it helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn off the Computer Problem trasher Linux - Hardware 13 04-16-2005 06:55 PM
computer building problem Zhou Yi Linux - Hardware 6 12-13-2004 09:36 AM
My Computer icon problem philburge SUSE / openSUSE 2 11-21-2004 01:10 AM
Computer Problem... Please Help Iman986 General 5 09-14-2003 09:54 PM
computer power problem ronss Linux - Hardware 3 08-06-2002 04:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration