LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-27-2017, 02:38 PM   #1
steve francis
LQ Newbie
 
Registered: Apr 2010
Distribution: Linux Mint 17
Posts: 16

Rep: Reputation: 0
Problem with booting when network drive NOT connected


I have a laptop running Linux and Windows in a dual boot configuration.

I have configured the Linux boot up to automatically mount a network drive (nfs) on start up by adding a line to the /etc/fstab/ file. All works well.

However, when I take the laptop to another location (i.e. where the network drive is not physically connected), it takes an age to boot up. Eventually it does, but I have to wait over a minute. (Presumably it's spending this time looking for the network drive before giving up.)

Am I stuck with this? Ideally, at the boot menu, I would like options that say
1. Linux (ignore network drives at start up)
2. Linux
3. Windows

At the moment, the boot menu only gives me options 2 and 3 to choose from.
 
Old 01-27-2017, 02:54 PM   #2
Pearlseattle
Member
 
Registered: Aug 2007
Location: Zurich, Switzerland
Distribution: Gentoo
Posts: 995

Rep: Reputation: 128Reputation: 128
Hi

The "menu" you're referring to is probably the boot menu, right?

If yes, then in that menu you'll be able to configure only stuff related to the kernel and its modules.
The "mount" of nfs happens only later, once the rootfs has been mounted and the options of /etc/fstab have been read and are being executed.
Therefore, most probably you cannot fix your problem by creating an additional menu-entry or changing how the existing ones work.

To cut it short you might be able to fix your problem by specifying in /etc/fstab some additional options for your nfs-mount. Basically what you want is that it shall not "block" if there are "problems" mounting the remote share.
The options that might be relevant for your are e.g. "bg" and "soft".
More informations e.g. in this thread.

Fyi, if at a certain point you'll have to manage more remote "stuff", then you might want to have a look at "glusterfs" - it has e.g. great non-blocking management of remote shares that (for any reason) keep on get offline and then back online.

Cheers
 
Old 01-27-2017, 03:10 PM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 19,518

Rep: Reputation: 3134Reputation: 3134Reputation: 3134Reputation: 3134Reputation: 3134Reputation: 3134Reputation: 3134Reputation: 3134Reputation: 3134Reputation: 3134Reputation: 3134
Other options are to not mount the network drive i.e. use noauto,users so it can be manually mounted as desired.

Use autofs or auto.systemd to only mount the network drive when you access its mount point. After a timeout period it is automatically unmounted.
 
Old 01-27-2017, 08:32 PM   #4
steve francis
LQ Newbie
 
Registered: Apr 2010
Distribution: Linux Mint 17
Posts: 16

Original Poster
Rep: Reputation: 0
Thanks for your suggestions.

The nobootwait option in /etc/fstab didn't work for me. I shall experiment with the other solutions that you have proposed
 
Old 01-27-2017, 11:06 PM   #5
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,511

Rep: Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007
I think the noauto option works. I get the same problem with USB drives in fstab.
 
Old 01-28-2017, 12:24 PM   #6
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,234

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
Quote:
Originally Posted by AwesomeMachine View Post
I think the noauto option works. I get the same problem with USB drives in fstab.
I can confirm that the solution mentioned by both michaelk and AwesomeMachine is what you're looking for : the noauto option in fstab. I solved the exact same problem you had 5 years ago that way and I still use that option for network shares in my fstab on laptops that are sometimes out of the house. The only thing you must remember is that the shares will be unmounted at boot, even when you are connected to your network, until you access them. I prefer this in any case, personally.

Cheers :-)

Last edited by Rickkkk; 01-28-2017 at 12:33 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
network manager shows connected to wifi but ifconfig show connected to ethernet mia_tech Linux - General 10 12-16-2015 11:23 AM
[SOLVED] Mounting a drive that isn't yet connected on the network veeruk101 Linux - Newbie 2 07-16-2011 02:16 PM
[SOLVED] How can I find the IP address of connected network drive? giddensg Linux - Networking 3 04-01-2011 01:43 AM
booting problem with adaptec 3805 raid connected m_kane Linux - Server 1 11-18-2010 09:48 AM
Mounting a windows drive on a Linux machine (connected via an ethernet network) eddydw Linux - Networking 13 01-03-2009 04:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration