LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-14-2008, 11:35 AM   #1
iBOT
LQ Newbie
 
Registered: Feb 2008
Posts: 3

Rep: Reputation: 0
Question Problem Wit Firefoxt


hi Guys ..
Umm...... i'm a Noob in Linux just installed after a lot of battle wit my Windows
...and i googled about the desktop effect problem and came across this site...
well.. some solution about downloadin' Drivers for nVidia was posted(i have a 6200)
..well my Query is that ..
the browser(Firefox)doesn't open at all.. "startin Firefox" and thats it BLANK....or a blank screen after firefox opens...(why don't they have a -server not found-thingy in Linux..)
even if i try to run again it says "Restart ur sys, firefox busy" blah,blah,blah...
so it'll be really helpful if u look into this..
Cheers,
iBOT.....

{forgive any Typos)
 
Old 02-15-2008, 04:46 AM   #2
abonnema
LQ Newbie
 
Registered: Jun 2004
Location: The Netherlands
Distribution: Fedora (KDE)
Posts: 7

Rep: Reputation: 0
Hi ibot,

Your question is difficult to answer, as you don't provide relevant information:

1. What hardware are you using (32 bit, 64, pentium compat or otherwise)?

2. What distribution are you running? Most distributions have their own installation and update procedures

3. What OS are you running i.e. name and version? I would include the output from uname -a.

4. What did you do to install Firefox? Did you use the distributions installation procedures? Or did you install using the FireFox's website. The installation procedure of your distribution is always better.

5. You did not describe the problem clearly. Your text contains some utterance of a video card problem, of a server not found etc.
And a "-thingy" and "blah, blah, blah" does not help in describing the problem. Please be as precise as possible. Preferably: show the exact error message.

In other words, be as complete *and* as concise as possible, if you want an answer to your question.

Guus.
 
Old 02-15-2008, 11:17 AM   #3
iBOT
LQ Newbie
 
Registered: Feb 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Unhappy Problem With Firefox :part2 (lol)


ok...
I see that I was not precise now.. sorry guys..
well to make up for it i'll describe my prob as exxzct as possible...

1.Hardware:Intel P4-HT clock speed 3.06GHz,
nVidia 6200LE AGP 8X,VIA Mum board(chipset dunno),
1.5GB RAM(DDR).....
2.Linux Dist: Fedora 8(codenamed:werewolf) installed from a DVD not from a
live CD or any other image
3.OS: Dual Boot-Win XP(sp2) & Fed 8 Linux
4:Firefox Source: Dunno, it came wit the Fedora installation DVD


5. REAL PROBLEM:
i just wanted to enable the desktop effects on fedora, the "wobble" of the windows when u move 'em.. but i wasn't able to do so..
so i Googled about the problem and i found tis Cool forum.. in it a user had posted a similar query and another had replied-"try downloading the drivers for ur nVidia driver".....i tried to do the same(well u need a browser to download anything),and Firefox was in Fedora(being a fan of it i was thrilled to find it on Fedora but to my dismay Firefox won't start up... a message "Starting Firefox" comes up in the taskbar(the bottom panel,u know, where the legendary START button of windows lies usually, i don't know the name in Fedora)and nothin shows up in the desktop..... the wallpaper just blinks at me....
when i try to start Firefox again another message pops up on the Display-"Firefox is already running or its is busy, u need to close Firefox or restart ur system"...
This is my Situation .. so pls help.. i think i have povided ample Info..



loookin forward for a solution..
iBOT
 
Old 02-15-2008, 12:07 PM   #4
abonnema
LQ Newbie
 
Registered: Jun 2004
Location: The Netherlands
Distribution: Fedora (KDE)
Posts: 7

Rep: Reputation: 0
Okee, that looks a lot better.
Lets do one at a time:

1. For the wobbly bit to work, you need the non-GPL extensions to your video card. I strongly suspect that you do *not* need firefox to do that. What you need to find out is the name of the Fedora software installation routine and invoke that. It probably is in your menu (I suspect under System) somewhere. From that utility you should be able to find and install the appropriate video drivers.

If I remember properly, there is yum, with which you can download and install packages presuming you know the name.

There are also GUI frontends to yum, maybe kyum is a good one.
There may well be other package utilities in the GUI, depending on whether you installed them or not.

From the package manager, look for the propriety nvidia drivers.
Mark you, your kernel will be marked tainted.

2. Firefox problem
If you want to solve the firefox problem, please start firefox from the commandline (i.e. open a terminal and issue the command firefox).
If anything goes wrong, the terminal window will display the error messages. If you start from the GUI, then the error messages get swallowed, not nice.

If firefox is still busy, just log off (I don't think restart is necessary) and log on again. You should be able to start firefox from the command prompt.

Also, if you want the system says that firefox is busy, and you want to kill it, use ps (f.i. "ps axuw | grep -i firefox | grep -v grep" and you should see any processes that have are named firefox. You kan kill that with a kill -9 <processnumber>
ALternatively, you can use the GUI program KSysguard (something like that). Probably gnome has something like that too.

If I were you, I would fix the firefox problem. In the meantime you could use Konqueror or Opera or something. Use the package manager to find out what you can install.

Hope this helps.

Guus.
 
Old 02-18-2008, 10:27 AM   #5
iBOT
LQ Newbie
 
Registered: Feb 2008
Posts: 3

Original Poster
Rep: Reputation: 0
ThanX abonnema...
i understood a lil.. will try out and as my OS Proffessor says whenever we ask him a Question - "Explore"
and hopefully will get a good result
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem wit marvell yukon network card? ARCIS_house Linux - Networking 2 03-22-2006 06:54 AM
problem wit GRUB..post 6.0 install JusCrzn Linux From Scratch 6 12-24-2004 01:25 PM
problem wit x or maybe xwindow? starguymike04 Debian 5 08-19-2004 01:31 PM
PS/ 2mouse problem wit kernel2 .6-beta10-r1 safrout Linux - Hardware 1 05-31-2004 07:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration