LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-02-2006, 11:30 AM   #16
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30

hi again

now i'm trying to install using rpms.

so it needs libxorg-x11..rpm ok during its installation i got a message
Quote:
/usr/X11R6/bin/xauth is needed by (installed) mkxauth-1.7-8mdk
so i download it and istall it(mkxauth-1.7-8mdk),when get back to install libxorg-x11..rpm i got the same pblm ,i downloaded an other mkxauth-1.7-8mdk and do the same step so same pblm

so please what's the solution?

thanks
 
Old 09-02-2006, 01:25 PM   #17
debiant
Member
 
Registered: Jul 2006
Distribution: Source Mage 0.9.6
Posts: 196

Rep: Reputation: 30
Ok, obviously rpm doesn't handle dependency (never used it) but yum does so download and install yum and then man yum to find out hwo to use.
 
Old 09-04-2006, 08:21 AM   #18
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30
Hi again

now i'm installing using rpms,the pblm i had before is that i downloaded rpms not for my distro,so every thing was ok.
during an istallation of per-base-5.8.7-3mdk pakage,so
the graphical rpm manager (rpmdrake)does not work,and many other gui programs do not work(i do not know why)like mozilla,and the worst thing is that i missed my Desktop after a restart(i have the Desktop dir in my personal dir).now i'm installing using shell(commands).

ok i will inform you about the new strange errors that i will get
many thanks
 
Old 09-05-2006, 04:30 PM   #19
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30
salam

while installing perl-TK it needs the perl-base
i want to install perl-base-5.8.7-3mdk.i586.rpm
so i got an error message:
Quote:
erreur: Dépendances requises:
perl-base = 2:5.8.5-3mdk est nécessaire pour (déjà installé) perl-5.8.5-3mdk
which means:

error:dependance required
perl-base = 2:5.8.5-3mdk is necessary for (already installed) perl-5.8.5-3mdk

i downloaded perl-base-5.8.5-3mdk then i got an warning message saying that perl-base-5.8.5-3mdk is already installed.i tried with perl-5.8.7-3mdk i got an error message saying :
Quote:
perl-base = 2:5.8.7-3mdk is necessary for perl-5.8.7-3mdk
so when installing perl-base-5.8.7-3mdk i got an error message like the one which is the first.

so i can't fix the problem ,please any suggestions are welcome

thanks in advance
 
Old 09-05-2006, 09:59 PM   #20
debiant
Member
 
Registered: Jul 2006
Distribution: Source Mage 0.9.6
Posts: 196

Rep: Reputation: 30
how bad would a reinstall be at this point? It seems that your dependencies are pretty screwed up. Do you have an Installation CD, if so make sure you install yum with your installation.
 
Old 09-06-2006, 07:45 AM   #21
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30
i think i'm going to stop this because i losed many things,so i can convert chm to pdfs.
so can u help me to get back my desktop?
i have an other pblm is that the kde is not lunched at the boot,uhave to wait several minutes.i do not know why.
so any ideas
thanks
 
Old 09-06-2006, 08:41 PM   #22
debiant
Member
 
Registered: Jul 2006
Distribution: Source Mage 0.9.6
Posts: 196

Rep: Reputation: 30
Like I said, is reinstalling an option? Because there is alot that seems to be pretty messed up. I'd say with all the time you spent trying to get this to work, you could have reinstalled with xchm already installed.
 
Old 09-07-2006, 08:59 AM   #23
adilturbo
Member
 
Registered: Jun 2006
Location: morocco
Posts: 195

Original Poster
Rep: Reputation: 30
ok thanks

so is there a solution to get back my desktop?

thank you
 
Old 01-24-2008, 04:33 PM   #24
jaf12466
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
Wink

Quote:
Originally Posted by adilturbo View Post
for LD_LIBRARY_PATH i did not find it with the set command(please what's its goal). but i configured the /etc/ld.so.conf added the /usr/local/lib path, then moving to to pango(also needed by GTK+) so it needs the fontconfig.pc i installed it, then moved to cairo(also requested by GTK+).the pblm i had is that i tough that installing glib-2.12.0 so i should find glib-2.12.0.pc,in fact it is glib-2.0.pc

so now during the cairo configure i got message:


so please what is the solution?

many thanks
---hey


This works for me!
cd cairo-1.2.6
./configure --disable-png --disable-win32

(just read the README!!)

bye.
Jaf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xchm error NNP Linux - Software 1 08-25-2006 06:38 AM
Problem with Xchm viewer for linux Thatusr Linux - Software 11 01-22-2006 03:01 PM
xchm problem kb_ganesh Red Hat 0 07-24-2005 02:23 AM
xchm problem Nizzuri Linux - Newbie 5 08-16-2004 11:49 PM
xchm problem Nizzuri Linux - Software 1 08-15-2004 05:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration