LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problem trying to install aptitude (https://www.linuxquestions.org/questions/linux-newbie-8/problem-trying-to-install-aptitude-576420/)

jacatone 08-11-2007 06:07 PM

Problem trying to install aptitude
 
I'm running Kubuntu 7.04 and downloaded a deb of Aptitude and tried installing it using Synaptic, Kpackage and Konsole. Keep getting the same result:

Unpacking replacement aptitude ...
dpkg: dependency problems prevent configuration of aptitude:
aptitude depends on libapt-pkg-libc6.3-6-3.11; however:
Package libapt-pkg-libc6.3-6-3.11 is not installed.
dpkg: error processing aptitude (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
aptitude

When I trying installing libapt-pkg-libc6.3-6-3.11, I get this:

Package libapt-pkg-libc6.3-6-3.11 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libapt-pkg-libc6.3-6-3.11 has no installation candidate

Synaptic did say it was "broken" whatever that means.


How to I fix this? Thanks.

Junior Hacker 08-12-2007 03:53 AM

If you copy and paste that package name in the Google search field, you'll get this link to the package:
http://packages.debian.org/unstable/...libc6.3-6-3.11
Notice the word "unstable", this is a Debian Sid/unstable package.
If you really need it you can add this line in your apt sources.list, but comment it out after installing the package as this is not a Ubuntu repo:
deb http://ftp.debian.org/debian/ unstable main contrib non-free
Or download the package that provides it as listed from the link above for your architecture and install with dpkg, there may be more dependency issues doing it this way.

archtoad6 08-15-2007 08:00 AM

Was aptitude not included in your Kubuntu install?

This list indicates that it was, while this one says it was not. The 2nd one is so short I think it's incomplete.

Is this a replacement or upgrade?


All times are GMT -5. The time now is 01:35 PM.