LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-07-2012, 02:20 PM   #1
J.A.X
Member
 
Registered: Jan 2010
Distribution: Fedora 19
Posts: 83

Rep: Reputation: 3
Problem starting apache


Hi guys,

I've tried to start my http daemon many times but it says :

PHP Code:
[root@localhost ~]# /etc/init.d/httpd start
Starting httpd (via systemctl):  Job failedSee system logs and 'systemctl status' for details.
                                                           [
FAILED
When I logged last time (before a restart) apache worked fine ....

can you please help me
 
Old 01-07-2012, 02:35 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Hi J.A.X,

Which distribution are you using?

Could you please paste the apache error log so that we can have a look.
 
Old 01-07-2012, 02:39 PM   #3
J.A.X
Member
 
Registered: Jan 2010
Distribution: Fedora 19
Posts: 83

Original Poster
Rep: Reputation: 3
Hi T3RM1NVT0R,

I'm using Fedora 16.

The apache error log is located at /var/log/httpd

but there are many files there, which one you need

thank you T3RM1NVT0R
 
Old 01-07-2012, 02:50 PM   #4
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Please paste the output of the following:

1.
Code:
cat /var/log/messages
2.
Code:
cat /var/log/httpd
 
Old 01-07-2012, 03:08 PM   #5
J.A.X
Member
 
Registered: Jan 2010
Distribution: Fedora 19
Posts: 83

Original Poster
Rep: Reputation: 3
I've attached the /var/log/messeges file

and the /var/log/httpd is a directory and here are its contents :

[root@localhost khalid]# ls /var/log/httpd/
total 84
drwx------. 2 root root 4096 Sep 13 15:28 ./
drwxr-xr-x. 19 root root 4096 Jan 7 23:16 ../
-rw-r--r--. 1 root root 0 Nov 25 16:10 access_log
-rw-r--r--. 1 root root 7591 Oct 9 03:51 access_log-20111013
-rw-r--r--. 1 root root 3567 Nov 12 22:08 access_log-20111125
-rw-r--r--. 1 root root 0 Nov 25 16:10 error_log
-rw-r--r--. 1 root root 9311 Oct 9 22:09 error_log-20111013
-rw-r--r--. 1 root root 29127 Nov 12 22:17 error_log-20111125
-rw-r--r--. 1 root root 0 Oct 13 21:07 ssl_access_log
-rw-r--r--. 1 root root 3336 Oct 8 13:01 ssl_access_log-20111013
-rw-r--r--. 1 root root 0 Oct 13 21:07 ssl_error_log
-rw-r--r--. 1 root root 4275 Oct 8 13:01 ssl_error_log-20111013
-rw-r--r--. 1 root root 0 Oct 13 21:07 ssl_request_log
-rw-r--r--. 1 root root 4458 Oct 8 13:01 ssl_request_log-20111013

thanx
Attached Files
File Type: txt messages.txt (204.1 KB, 7 views)
 
Old 01-07-2012, 03:23 PM   #6
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

Don't worry about error_log as I can see:

-rw-r--r--. 1 root root 0 Nov 25 16:10 error_log
-rw-r--r--. 1 root root 9311 Oct 9 22:09 error_log-20111013

The existing error log is showing as 0 KB and the other error log is old one. However in /var/log/messages I can see httpd encountering segfaults due to perl. Did you change anything in httpd configuration?

Here is the abstract on the basis of which I am thinking that some configuration is changed either on the perl end or at httpd end:

Jan 7 22:42:40 localhost kernel: [ 87.746410] httpd[1726]: segfault at d ip 00fdc9f5 sp bfea8910 error 4 in mod_perl.so[fc0000+33000]
Jan 7 22:42:40 localhost systemd[1]: httpd.service: control process exited, code=killed status=11
Jan 7 22:42:40 localhost systemd[1]: Unit httpd.service entered failed state.
Jan 7 22:42:52 localhost dbus-daemon[988]: ** Message: No devices in use, exit
Jan 7 22:46:56 localhost kernel: [ 343.993555] httpd[1747]: segfault at d ip 007e09f5 sp bf8a5510 error 4 in mod_perl.so[7c4000+33000]
Jan 7 22:46:56 localhost systemd[1]: httpd.service: control process exited, code=killed status=11
Jan 7 22:46:57 localhost systemd[1]: Unit httpd.service entered failed state.
Jan 7 22:47:00 localhost kernel: [ 347.220763] httpd[1758]: segfault at d ip 007409f5 sp bf832450 error 4 in mod_perl.so[724000+33000]
Jan 7 22:47:00 localhost systemd[1]: httpd.service: control process exited, code=killed status=11
Jan 7 22:47:00 localhost systemd[1]: Unit httpd.service entered failed state.
Jan 7 22:47:02 localhost systemd[1]: httpd.service: control process exited, code=killed status=11
Jan 7 22:47:02 localhost kernel: [ 349.316996] httpd[1769]: segfault at d ip 0065c9f5 sp bf806e30 error 4 in mod_perl.so[640000+33000]
Jan 7 22:47:02 localhost systemd[1]: Unit httpd.service entered failed state.
Jan 7 22:47:37 localhost kernel: [ 384.590879] httpd[1795]: segfault at d ip 003d09f5 sp bffe5df0 error 4 in mod_perl.so[3b4000+33000]
Jan 7 22:47:37 localhost systemd[1]: httpd.service: control process exited, code=killed status=11
Jan 7 22:47:37 localhost systemd[1]: Unit httpd.service entered failed state.
Jan 7 22:47:39 localhost kernel: [ 386.059580] httpd[1806]: segfault at d ip 007ce9f5 sp bf830580 error 4 in mod_perl.so[7b2000+33000]
Jan 7 22:47:39 localhost systemd[1]: httpd.service: control process exited, code=killed status=11
Jan 7 22:47:39 localhost systemd[1]: Unit httpd.service entered failed state.
Jan 7 22:47:40 localhost kernel: [ 387.285085] httpd[1817]: segfault at d ip 0053b9f5 sp bf9fb1e0 error 4 in mod_perl.so[51f000+33000]
Jan 7 22:47:40 localhost systemd[1]: httpd.service: control process exited, code=killed status=11
Jan 7 22:47:40 localhost systemd[1]: Unit httpd.service entered failed state.

Run the following command and see if anything get updated in error_log:

1. service httpd stop
2. service httpd start

Then run:

cat /var/log/httpd/error_log
 
1 members found this post helpful.
Old 01-07-2012, 03:28 PM   #7
J.A.X
Member
 
Registered: Jan 2010
Distribution: Fedora 19
Posts: 83

Original Poster
Rep: Reputation: 3
Nothing new, the file is still 0 KB

[root@localhost khalid]# service httpd stop
Stopping httpd (via systemctl): [ OK ]
[root@localhost khalid]# service httpd start
Starting httpd (via systemctl): Job failed. See system logs and 'systemctl status' for details.
[FAILED]

I think I've messed up my Fedora (in purpose of learning ), now my audio driver is not working too.

thank you T3RM1NVT0R for trying to help

but I'm goiong for re-installation.

Last edited by J.A.X; 01-07-2012 at 03:30 PM.
 
Old 01-07-2012, 03:34 PM   #8
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
@ Reply

You're welcome. Just a bit of advice. If you are using distribution/distributions for learning purpose then install them as virtual machine. Take a base snapshot. This will save you from re-install time/headache involved.

Please mark the thread as solved if you no longer require suggestions on this one.

Enjoy linux!!!
 
Old 01-07-2012, 03:44 PM   #9
J.A.X
Member
 
Registered: Jan 2010
Distribution: Fedora 19
Posts: 83

Original Poster
Rep: Reputation: 3
thanks for your advice, I will install a virsual box in windows, I think this will save me alot of time.

cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem Starting apache. uiuiui172 Linux - Server 7 08-02-2009 02:21 AM
problem starting an Apache sulacco Linux - Software 1 05-01-2009 10:06 AM
problem starting apache anilbh Fedora 11 07-04-2007 08:12 PM
Problem starting apache. Please help! cojo Linux - Software 8 01-10-2006 11:47 PM
Problem starting apache nrmx Linux - Networking 2 03-13-2003 10:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration