LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-08-2005, 04:00 PM   #1
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Rep: Reputation: 30
Problem setting user quotas


Hi all,

I have VSFTPD installed, and it's working really well.

What I want to do is create new users, assign them a home directory, and limit their disk quotas to certain sizes depending on a few things.

In this case, I made a user called 'ftp123test' and am trying to assign him a disk quota of 100MB.

In fstab, quotas are enabled. I ran 'edquota ftp123test' and set hard and soft to 100, like so:

Code:
[root@u15157697 /]# quota -v ftp123test
Disk quotas for user ftp123test (uid 10032):
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
      /dev/hda3       0     100     100               0       0       0
[root@u15157697 /]#
Which I *think* is correct. However when I login to the FTP server as him, I still get the "Quotas off" message.

Code:
200 PORT command successful
150 Opening ASCII mode data connection for file list
-rw-r--r--   1 ftp123test ftp123test    31503 Feb  8 20:39 ViperVsEvo1-vi.jpg
-rw-r--r--   1 ftp123test ftp123test   110984 Feb  8 20:40 artpad.jpg
226-Transfer complete.
226 Quotas off
ftp>
What am I missing? Thanks in advance.
 
Old 02-08-2005, 04:04 PM   #2
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Original Poster
Rep: Reputation: 30
And here's my /etc/fstab:

Quote:
[root@u15157697 /]# cat /etc/fstab
/dev/hda3 / ext3 defaults,usrquota 1 1
/dev/hda1 /boot ext3 defaults 1 2
Home directories (the only place I want Quotas) are on hda3.
 
Old 02-08-2005, 04:07 PM   #3
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Original Poster
Rep: Reputation: 30
Also tried:

Code:
[root@u15157697 /]# quotaon -avug
/dev/hda3 [/]: user quotas turned on
[root@u15157697 /]#
Same message logging into FTP though.
 
Old 02-09-2005, 08:47 AM   #4
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Original Poster
Rep: Reputation: 30
Bump~
 
Old 02-09-2005, 11:41 AM   #5
darkRoom
Member
 
Registered: Mar 2004
Location: Valencia, espaņa
Distribution: Slack, Gentoo, Custom
Posts: 162

Rep: Reputation: 30
Try using 'quotacheck'

Also 'repquota -a' will show all users quotas and statuses
 
Old 02-10-2005, 10:38 AM   #6
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Original Poster
Rep: Reputation: 30
Quotacheck returns me nothing, no errors either.

repquota - a returns:

Code:
ftp123test +-     148     100     100  7days       3   100   100
So it looks like they're on, but just not being recognized in my FTP software.
 
Old 02-11-2005, 11:03 AM   #7
Seventh
Member
 
Registered: Dec 2003
Location: Boston, MA
Distribution: Redhat / Debian
Posts: 269

Original Poster
Rep: Reputation: 30
:\ Still can't figure this out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Quotas: Setting them Swakoo Linux - Newbie 1 10-27-2005 08:59 AM
copying user quotas from proto user jomy Linux - Enterprise 0 01-09-2005 03:06 AM
Setting Up Filesystem Quotas j_miguel_y Linux - Software 0 06-09-2004 11:21 AM
User Quotas Dipdngold Linux - General 2 01-21-2004 06:47 PM
Setting up User Quotas? Uncreative Slackware 3 05-11-2003 09:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration