-   Linux - Newbie (
-   -   problem printing with usb to parallel adapter with an hp 720c (

pernest 03-25-2010 11:32 AM

problem printing with usb to parallel adapter with an hp 720c

I'm having a nightmare getting an old hp deskject 690c to print consistently when connected through a usb to parallel cable.

I've got a fresh install of ubuntu 9.10 on a fresh disk and everything was going perfectly. I bought a Usb=>parallel cable to connect my old parallel port printer.

When I try and print, sometimes it works and sometimes it doesn't. Sometimes the job will go to the print queue and then nothing happens, in this case if I unplug and replug the usb cable a couple of times it usually prints the document. Sometimes the job doesn't show up in the print queue at all and sometimes it prints the document with no problems.

Whenever I use lsusb, I never see the printer in the list of attached usb devices (even when the printer is printing!). Apart from root hubs, the only two devices ever listed with lsusb are my mouse and scanner.

What tests can I run to try and pin this problem down?

Many thanks for any help.


Drakeo 03-26-2010 08:19 AM


Common Unix Printing System)
You may want to go back and configure your CUPS. and let CUPS configure it as a usb device.
delete old printer then add printer and let CUPS find it.
When you do a cold boot you will hear your printer come on line. That means the bios recognize the usb and probed that device. Printers are run at a very low level.
This goes way back to print from BIOS. If CUPS sees it as Parallel then let me know.

pernest 03-26-2010 09:07 AM

Thank you very much for the reply.

I followed the steps you described but to no avail. I deleted the printer from the command line using lpadmin -x DESKJET-720C
I then used printer configuation tool in ubuntu. It detected and configured the printer as a usb printer with no problems and successfully printed a test page. I was then able to print a page from open office. Then when I tried to print from gedit the job went to the print queue but nothing came out of the printer, the print queue listed the job as 'processing'. Then trying to print from open office again, the job went to the queue but nothing came out. Turning the computer off and on again, the jobs were still in the print queue, but listed as 'held', when I clicked release they both printed without a problem.

The printer still does not show up in the list when I use lsusb. I don't understand why this could be. I thought lsusb listed ALL attached usb devices, and the printer is certainly attached through a usb port!

Any further help will as always be gratefully received.

All times are GMT -5. The time now is 01:14 PM.