LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-14-2012, 03:16 PM   #1
PayNow
LQ Newbie
 
Registered: Jun 2012
Posts: 7

Rep: Reputation: Disabled
Problem installing php5


hello i have debian i am trying to install php mysql-server apache2 & phpmyadmin but i am getting this

Quote:
root@ks3094026:/etc# apt-get -f install apache2 mysql-server phpmyadmin php5
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
php5 est déjà la plus récente version disponible.
phpmyadmin est déjà la plus récente version disponible.
apache2 est déjà la plus récente version disponible.
mysql-server est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
3 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n]*?
Paramétrage de apache2.2-common (2.2.16-6+squeeze10) ...
ERROR: Site default does not exist!
dpkg*: erreur de traitement de apache2.2-common (--configure)*:
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
dpkg*: des problèmes de dépendances empêchent la configuration de apache2-mpm-worker*:
apache2-mpm-worker dépend de apache2.2-common (= 2.2.16-6+squeeze10)*; cependant*:
Le paquet apache2.2-common n'est pas encore configuré.
dpkg*: erreur de traitement de apache2-mpm-worker (--configure)*:
problèmes de dépendances - laissé non configuré
dpkg*: des problèmes de dépendances empêchent la configuration de apache2*:
apache2 dépend de apache2-mpm-worker (= 2.2.16-6+squeeze10) | apache2-mpm-prefork (= 2.2.16-6+squeeze10) | apache2-mpm-event (= 2.2.16-6+squeeze10) | apache2-mpm-itk (= 2.2.16-6+squeeze10)*; cependant*:
Le paquet apache2-mpm-worker n'est pas encore configuré.
Le paquet apache2-mpm-prefork n'est pas installé.
Le paquet apache2-mpm-event n'est pas installé.
Le paquet apache2-mpm-itk n'est pas installé.
apache2 dépend de apacconfigured to not write apport reports
configured to not write apport reports
configured to not write apport reports
he2.2-common (= 2.2.16-6+squeeze10)*; cependant*:
Le paquet apache2.2-common n'est pas encore configuré.
dpkg*: erreur de traitement de apache2 (--configure)*:
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution*:
apache2.2-common
apache2-mpm-worker
apache2
E: Sub-process /usr/bin/dpkg returned an error code (1)
IN ENGLISH

Quote:
ks3094026 root @ :/ etc # apt-get-f install apache2 php5 mysql-server phpmyadmin
Reading package lists ... Fact
Building dependency tree
Reading state information ... Fact
php5 is already the newest version.
phpmyadmin is already the newest version.
apache2 is already the newest version.
mysql-server is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Would you like to continue [Y / n] *?
Setting apache2.2-common (2.2.16-6 + squeeze10) ...
ERROR: default website does not exist!
dpkg: error processing apache2.2-common (- configure) *:
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apache2-mpm-worker *:
apache2-mpm-worker depends on apache2.2-common (= 2.2.16-6 + squeeze10) * however *:
Package apache2.2-common is not configured yet.
dpkg: error processing apache2-mpm-worker (- configure) *:
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apache2 *:
apache2 depends on apache2-mpm-worker (= 2.2.16-6 + squeeze10) | apache2-mpm-prefork (= 2.2.16-6 + squeeze10) | apache2-mpm-event (= 2.2.16-6 + squeeze10) | apache2-mpm-itk (= 2.2.16-6 + squeeze10) * however *:
Package apache2-mpm-worker is not configured yet.
Package apache2-mpm-prefork is not installed.
Package apache2-mpm-event is not installed.
Package apache2-mpm-itk is not installed.
apache2 depends apacconfigured contribution to not write reports
configured to not write contribution reports
configured to not write contribution reports
he2.2-common (= 2.2.16-6 + squeeze10) * however *:
Package apache2.2-common is not configured yet.
dpkg: error processing apache2 (- configure) *:
dependency problems - leaving unconfigured
Errors were encountered while processing *:
apache2.2-common
apache2-mpm-worker
apache2
E: Sub-process / usr / bin / dpkg returned an error code (1)
Please help me it bit urgent
 
Old 12-15-2012, 07:59 AM   #2
hamzar.pm
Member
 
Registered: Aug 2009
Location: India,Kerala,Cochin
Distribution: Fedora 11 ,Centos, ubuntu, Redhat
Posts: 42

Rep: Reputation: 1
sudo apt-get install -f
please post the output for this

OR
This thread may help you
http://ubuntuforums.org/showthread.php?t=1642173

Last edited by hamzar.pm; 12-15-2012 at 08:01 AM.
 
Old 12-15-2012, 08:12 AM   #3
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 (pre-systemd)
Posts: 2,849

Rep: Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757
Although my French is a little rusty, I think the first error is:
Code:
Configuring apache2.2-common (2.2.16-6 + squeeze10) ...
ERROR: site default does not exist!
dpkg: error processing apache2.2-common (- configure) *:
I imagine that "site default" refers to the DocumentRoot directory
specified in the apache2.conf file. Normally:

Code:
DocumentRoot "/usr/share/apache2/default-site/htdocs"
Make sure you have this pointing to an existing directory.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
installing php5 sunils1973 Linux - Software 4 11-27-2007 10:40 AM
installing src php5 or tar php5 step by step jatender Linux - Software 2 06-28-2007 11:29 AM
problem when installing and configure PHP5 ketut_hendratha Linux - Newbie 2 08-22-2006 09:48 PM
installing apache2+php5+mysql4 problem yangying Linux - Software 5 04-21-2005 02:24 AM
Installing PHP5 varunbihani Linux - Software 0 01-07-2005 07:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration