LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-03-2005, 04:26 AM   #1
chris2pher_28
LQ Newbie
 
Registered: Sep 2005
Location: Manila
Posts: 6

Rep: Reputation: 0
problem installing Linux


hello people,

hi im switching from windows operating system to linux with GUI but the problem is that in other PC, linux don't run on its GUI instead it boots up in a command line linux. I'm trying to install it on Dell Optiplex 170L and i don't know what the problem is. Cox it runs on different machine with the same specification. please give some advice. thanx

chris
 
Old 09-03-2005, 04:27 AM   #2
dinolinux
Member
 
Registered: Jun 2005
Location: Oslo, Norway
Distribution: Slackware 11, Solaris 10, Solaris 9, Sourcemage 0.9.6
Posts: 322

Rep: Reputation: 31
Which distro are you using?
 
Old 09-03-2005, 05:38 AM   #3
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
Most distros if got GUI packaged in will answer the following call in the terminal mode

startx

Last edited by saikee; 09-03-2005 at 09:17 AM.
 
Old 09-03-2005, 08:10 AM   #4
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
Hello there,
As "saikee" stated that from console you can go to GUI using "startx" command.
check out your /etc/inittab file.
for reference i'm showing my systems /etc/inittab file

Code:
root@bond:~# cat /etc/inittab
#
# inittab       This file describes how the INIT process should set up
#               the system in a certain run-level.
#
# Version:      @(#)inittab             2.04    17/05/93        MvS
#                                       2.10    02/10/95        PV
#                                       3.00    02/06/1999      PV
#                                       4.00    04/10/2002      PV
#
# Author:       Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
# Modified by:  Patrick J. Volkerding, <volkerdi@slackware.com>
#

# These are the default runlevels in Slackware:
#   0 = halt
#   1 = single user mode
#   2 = unused (but configured the same as runlevel 3)
#   3 = multiuser mode (default Slackware runlevel)
#   4 = X11 with KDM/GDM/XDM (session managers)
#   5 = unused (but configured the same as runlevel 3)
#   6 = reboot

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

# System initialization (runs when system boots).
si:S:sysinit:/etc/rc.d/rc.S
now have a look at the line #Default runlevel (Do not set to 0 or 6)
id:3:initdefault:

this particular line "id:3:initdefault:" is the setting.
on my system it always takes me to console from there i type "startx" to go to GUI.
but if i make it "id:5:initdefault:" i'll be taken to GUI directly.

Depending on the distro you r using you will have the settings...........so check out your /etc/inittab
regards

Edit: on my system if i make it to 4 i.e id:4:initdefault then i'll see the GUI everytime i boot my system

Last edited by b0nd; 09-03-2005 at 08:15 AM.
 
Old 09-05-2005, 02:08 AM   #5
chris2pher_28
LQ Newbie
 
Registered: Sep 2005
Location: Manila
Posts: 6

Original Poster
Rep: Reputation: 0
hello again people,
startx command did not run on terminal mode

when i enter startx command:

(= =) Log file: ?/var/log/Xorg.0.log?, Time: Mon Sep 5 10:03:30 2005
(= =) Using config file: ?/etc/X11.xorg.conf

(EE) I810(0): No Video BIOS modes for chosen depth
(EE) Screens found, but none have a usable configuration.

Fatal Error:
No screens found

XIO: fatal IO error 104 (Connection reset by peer) on S server ?0.0?
After 0 request (0 known processed) with 0 events remaining.

what should i do?
thankx for the replies.
 
Old 09-05-2005, 04:23 AM   #6
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
which distro are you using..???? and its better to display it under the "distribution: " heading with your screen name.

regards
 
Old 09-05-2005, 05:51 AM   #7
FrankP
Member
 
Registered: Aug 2003
Location: Britain
Distribution: Debian, MacOSX, FreeBSD
Posts: 65

Rep: Reputation: 18
Your X server needs reconfiguring. This is likely because the monitor or video hardware on this PC is different from the other box you said you had no trouble with.

As ruudra says, you need to tell us what distro you are using.

Were there any questions in the install about your video card and monitor? The installer often sets up the X server correctly and that is easier than configuring it yourself. So you could check the specs of these items and go through the installation again.
 
Old 09-05-2005, 10:12 AM   #8
saikee
Senior Member
 
Registered: Sep 2005
Location: Newcastle upon Tyne UK
Distribution: Any free distro.
Posts: 3,398
Blog Entries: 1

Rep: Reputation: 112Reputation: 112
I endorse that the problem is the installed Linux chosed an inappropriate video card or screen for the boot up. This can be rectified often by switching the displayer driver manually while in command mode.

Recent distros don't seem to have this problem now, at least on my hardware.
 
Old 09-05-2005, 07:12 PM   #9
chris2pher_28
LQ Newbie
 
Registered: Sep 2005
Location: Manila
Posts: 6

Original Poster
Rep: Reputation: 0
hello

sorry i forgot to mention the distro im using
im using a red hut with GUI

How could i configure my X server
please help im really am a newbie in Linux.
thankx!

chris
 
Old 09-05-2005, 08:52 PM   #10
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Rep: Reputation: 32
Quote:
Originally posted by chris2pher_28
hello again people,
startx command did not run on terminal mode

when i enter startx command:

(= =) Log file: ?/var/log/Xorg.0.log?, Time: Mon Sep 5 10:03:30 2005
(= =) Using config file: ?/etc/X11.xorg.conf

(EE) I810(0): No Video BIOS modes for chosen depth
(EE) Screens found, but none have a usable configuration.

Fatal Error:
No screens found

XIO: fatal IO error 104 (Connection reset by peer) on S server ?0.0?
After 0 request (0 known processed) with 0 events remaining.

what should i do?
thankx for the replies.
Hey Chris,

Now I am not very sure, but try this :
Open up your xorg.conf or xfree86.conf file. It's located in /etc/X11 (at least in Slack it is)
Go to the monitor section
Change the default depth there, i.e reduce it to some lower value. Note that the value that is uncommented (without # sign) is the one that is being used. Save the file and startx again.
Try this with different depths. Tell us what happened.

Some examples of this are :
Code:
#   DefaultDepth 8
#   DefaultDepth 16
   DefaultDepth 24
#   DefaultDepth 32

Here depth of 24 is being used
You could also try something like :
Code:
#   DefaultDepth 8
   DefaultDepth 16
#  DefaultDepth 24
#   DefaultDepth 32

Here depth of 16 is in use

As far as configuring the X server in redhat is concerned use this command :
redhat-config-xfree86
(as root)
and then follow the procedure choosing the most appropriate configurations for your system.

Post back what you find.

Last edited by koodoo; 09-05-2005 at 08:59 PM.
 
Old 09-05-2005, 09:41 PM   #11
boxerboy
Member
 
Registered: Jul 2005
Distribution: ubuntu5.04, ubuntu5.10, suse9.3, mandrake10.1, mandriva2006(beta), FC1-4, redhat9.0, debian sarge
Posts: 519

Rep: Reputation: 32
a peice of advice from me. if your trying to install red hat linux u should go with fedora core 4 i had redhat 9.0 and fedora core 4. fedora in my opnion is better but u wont knwo til u try.im running FC4 on a very very old pc and it sees video,sound,usb and everything else without a problem
 
Old 09-06-2005, 07:13 PM   #12
chris2pher_28
LQ Newbie
 
Registered: Sep 2005
Location: Manila
Posts: 6

Original Poster
Rep: Reputation: 0
hello again guys

thanks koodoo and others who replied for the help.

i tried redhat-config-xfree86 command but did not work on my system but instead i tried configuring my xorg.conf file just what koodoo has said and it worked, the GU Interface run but their is a small problem. The resolution is 640x480 coz i change DefaultDepth to 16. what should i do to my system so that it would run on 24 DefaultDepth?

thankx to all.

chris
 
Old 09-06-2005, 07:57 PM   #13
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Rep: Reputation: 32
My pleasure

Hey Chris, I do not think that the resolution problem is because of changing the depth. Maybe you will again have to edit your xorg.conf file and add "1024X768" resolution mode (or any other mode that your monitor can support at that depth.).

Here take a look at the screen's section of my xorg.conf file :

Code:
# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
    Identifier  "Screen 1"
    Device      "VESA Framebuffer"
    Monitor     "My Monitor"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.

#   DefaultDepth 8
#   DefaultDepth 16
   DefaultDepth 24
#   DefaultDepth 32

# "1024x768" is also a conservative usable default resolution.  If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)

    Subsection "Display"
        Depth       8
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes "1024x768" "800x600" "640x480"
    EndSubsection 
    Subsection "Display"
        Depth       24
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       32
        Modes "1024x768" "800x600" "640x480"
    EndSubsection

EndSection
Notice I am using a default depth of 24.
Now you are using default depth 16. Check to see that is "1024X768" present in the display subsection for depth 16. If not add it yourself, save the file and start X again.

I do not remember what the exact command was to configure the X server in RedHat. If I remember correctly, All of the redhat-config-* commands have been renamed to system-config-*.

Try someting like system-config-display or system-config-display --reconfigure and that should do the trick.

Hope this helps.
 
Old 09-07-2005, 02:21 AM   #14
chris2pher_28
LQ Newbie
 
Registered: Sep 2005
Location: Manila
Posts: 6

Original Poster
Rep: Reputation: 0
hi pips!

i tried configuring my xorg.conf file. so it look like this:

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 865"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

then when i configured it, it look like this:

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 865"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 32
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

But the problem is that it did not work..and i check other PC with the same specifications with the one I'm configuring and its xorg.conf look like this:

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 865"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

what should i do?
thanks

chris
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing linux ysrcvprasad Linux - Software 3 11-09-2004 11:12 PM
problem in installing LINUX? surya Linux - Software 7 08-21-2004 10:18 AM
problem installing linux skyline21 Linux - Newbie 4 09-12-2003 12:04 AM
Problem installing linux SMB3Master Linux - Distributions 6 08-18-2003 07:04 PM
problem installing linux 9.0 deca Linux - Software 10 07-23-2003 01:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration