LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problem installing giFT.... (https://www.linuxquestions.org/questions/linux-newbie-8/problem-installing-gift-90065/)

J_Bone 09-07-2003 12:40 AM

Problem installing giFT....
 
OK, I downloaded gift, cd'ed to it's directory and did the ol' ./configure.

However, I get the error:

checking for _vsnprintf... no
checking for lt_dlopen in -lltdl... no
checking ltdl.h usability... no
checking ltdl.h presence... no
checking for ltdl.h... no
configure: error:
libltdl support is temporarily required. Please install the appropriate
library and header files (which includes the -dev package). See config.log
for more details.


I'm running Mandrake 9.1. Can anyone tell me where I can get the missing files? Thanks

J

contrasutra 09-07-2003 12:42 AM

google.


Try searching google for libltdl


You could even try "URPMI".

J_Bone 09-07-2003 12:43 AM

OK, thanks, I'll report back :)

J_Bone 09-07-2003 01:08 AM

Well, as I look for this thing, I can't help but wonder, why don't the developers include all necessary software in the download?

If it's an issue of the size of the download, there could be a "full" or "stripped" version....

Anyways, I keep looking for this libltdl :)

contrasutra 09-07-2003 01:44 AM

Why dont they include dependancies?

Because if you included all the dependancies of a program, a 5MB program would be an 80MB download.

Linux is about modularity. "I already have that library, why should I have to install/download it again?".

J_Bone 09-07-2003 01:57 AM

OK, fair enough, but still, I can't find this file "libltdl".....

I searched numerous google returns and couldn't figure out how to use "URPMI".....

I see you point, I guess I was just a little frustrated :)

Thanks for the help though....

J

J_Bone 09-07-2003 04:06 AM

K, I need to back up....
 
Please, here my plea:

Can someone give a noob a simple, step-by-step on how to install giFT including the appropriate plug-ins? I am running Mandrake 9.1. Thanks a bunch

J :)

mhearn 09-07-2003 07:03 AM

libltdl is a part of libtool. Install libtool and libtool-dev

J_Bone 09-07-2003 01:41 PM

Thanks Mike
 
OK, I had a version of libltdl installed, but I guess it was an old one, so I uninstalled it and installed a different (newer) version. GiFT then "appeared" to install (after cd'ing to it's directory, doing ./configure, make and make install) but it still doesn't seem to work right.

It installed some files in /usr/local/bin, one executive file called gift, another called giftd, a perl program called giFT-setup, and a plain text doc called gift-setup.

Hmmm but that's as far as I got. I'll show a sample of the text in the plain doc:

main();

sub main
{
my $templates = find_templates ($datadir);
my $configed = find_configured ($confdir);

# no available templates, bogus install
if (scalar @$templates == 0)
{
print <<"__EOF__";

*** ERROR ***

No available configuration templates were found. This could mean that you
legitimately have none and need to install the giFT daemon properly or that
you have placed them in an alternate data directory than this script is
looking. The configuration template path being used is:

$datadir

__EOF__

return;
}

#
# Configuration modules which will be read from the available templates.
# This basically creates a new data structure which is a hash of module
# entries, including ->{path_cfg} and ->{path_tpl}. This data
# structure may be further trimmed through the condition below.
#
my $modules_hash = build_modules ($configed, $templates);

#
# If there have been previously configured modules, we need to ask the
# user if they'd like us to rebuild from available templates or only
# add new configuration templates to the confdir.
#
if (scalar @$configed > 0)
{
print <<"__EOF__";

*** WARNING ***

Previous configuration has been detected. This script is capable of
preserving that configuration and only adding from new available templates.
If you choose no, all presently installed configuration modules will be used
in place of any custom configuration you have. In the future, previous
configuration will be read and used as defaults, but this script does not
currently have such a feature.



So, I need a giFT daemon now? :cry: j/k

Can anyone make some sense of this info? Thanks

J

mhearn 09-07-2003 01:50 PM

Well, did you try running giFT-setup, or that program? They are programs, try running them, see what happens.....

J_Bone 09-07-2003 02:23 PM

Hmmm well yes, I tried doubleclicking them, the executables did nothing and the other two just displayed text. How would I run them from a command prompt?

Thanks

mhearn 09-07-2003 02:27 PM

just type their names and hit enter

J_Bone 09-07-2003 03:13 PM

OK Mike, I ran the setup, but when i try to run the executables I get this error:

[root@a3h33829y42al bin]# giFT
Segmentation fault
[root@a3h33829y42al bin]# giftd
[12:11] *** GIFT-WARNING: deprecated configuration found at /root/.giFT/gift.conf: looking for giftd.conf...
*** GIFT-FATAL: couldn't load protocol in file /usr/local/lib/giFT/libgiFT -V.la: file not found
*** Often times more information can be found in the log file or with the -v command line switch.
[root@a3h33829y42al bin]#

So, what now? :)

mhearn 09-07-2003 03:16 PM

try not running it as root

J_Bone 09-07-2003 03:23 PM

You're right, but now i get:

[john@a3h33829y42al bin]$ giftd
[12:21] *** GIFT-WARNING: deprecated configuration found at /home/john/.giFT/gift.conf: looking for giftd.conf...

*** ERROR: Your setup is incomplete ***

You will need to run gift-setup and be sure that you read absolutely
every configuration option (no, really). Some default configuration
values are considered illegal, and will raise this error message. If you
suspect that you have configured giFT properly, consult the conf files in
/home/john/.giFT/ for diagnostic purposes.

If you are still having problems you should consult the QUICKSTART guide
available from the standard giFT distribution.

I guess I did something wrong :)

I'll run setup again, although some of it is kinda abstract to understand.. Thanks again Mike


All times are GMT -5. The time now is 10:55 PM.