-   Linux - Newbie (
-   -   Problem installing Firefox 5 - version 'GLIBCXX_3.4.9' not found (

newbieShannon 07-06-2011 01:18 PM

Problem installing Firefox 5 - version 'GLIBCXX_3.4.9' not found
I'm a total newbie using an ASUS Eee PC netbook running Linux that I bought off in May of '09. It worked fine for a while, then the wireless stopped working, and I finally got it going again today by reinstalling Linux (I think that's what I did.). I was trying to open some site and got an error that my version of Firefox was out of date, so I downloaded 5.0 and attempted to install it. I now have a firefox directory under /opt with a file named 'firefox'. When I try to run it (as root) I get the following response:

/opt/firefox/firefox-bin: /usr/lib/ version 'GLIBCXX_3.4.9' not found (required by /opt/firefox/

I searched the forums for how to resolve this issue, and saw a recommendation to go to to find an "rpms". My (stupid?) question is: how do I do that when I don't have an operable browser on my netbook?

To install firefox 5 I followed the instructions I found here: I did "backup" my old Firefox launcher. At this point I'm quite willing to simply go back to my old version and live with all the "your browser is out of date" messages, if I can only have a browser back! So if someone could either help me get what Firefox 5 needs loaded, or help me get back to my old Firefox, I'd be grateful.


knudfl 07-06-2011 01:29 PM

Welcome to LQ.

GLIBCXX_3.4.9 : Means an object in (g)lib(std)c++

Either libstdc++ isn't installed. ( Or too old.)
The object "GLIBCXX_3.4.9" is included in e.g. libstdc++ version 4.3.2

If your OS is too old, then better go for Firefox 3.6.18


craigevil 07-06-2011 02:10 PM

Debian Wiki -

What distro are you using?

newbieShannon 07-06-2011 02:38 PM

I don't know what a distro is, let alone which one I'm using - sorry. How do I find out?

newbieShannon 07-06-2011 02:39 PM

I've also tried running my old firefox (firefox-old), and I get the same error.

knudfl 07-06-2011 03:33 PM

Some Eeepc have a very old Xandros OS :

The command to find the OS / version is probably : cat /etc/issue

newbieShannon 07-06-2011 03:43 PM

When I try cat/etc/issue I get no such file or directory.

The system info is as follows:
BIOS version: 0802
BIOS date: 07/07/2008
Software version: Eee PC
Build info: 2008-07-23 12:10
CPU type: Intel (R) Mobile Processor
Memory size: 512 MB
Motherboard version: x.xx
Battery status: on AC power

Duron 07-06-2011 03:51 PM


Originally Posted by newbieShannon (Post 4407118)
I don't know what a distro is, let alone which one I'm using - sorry. How do I find out?

Definitely take knudfl's advice and try installing the libstdc++ package. Since it's an eeePC, I'll assume it's running some sort of Debian-based distro; the way to install this package in the command line would be "sudo apt-get install libstdc++" or you can use Synaptic Package Manager to search for it.

rokytnji 07-06-2011 04:28 PM

Do a F2 restore to bring Xandros back to stock. Or. Uninstall Firefox completely using Xandros synaptic package manager. I won't recommend using apt-get as you sound like a new user and no telling what you might remove
using apt-get remove.

Then follow eeepc wiki to update firefox 2 to firefox 3

Do Not try to update to Firefox 4 or 5 in Xandros 4 which is based on Debian Etch. Your libraries are too old and EEEForum is chock full of posts like yours.

I ditched Xandros long ago because of situations like yours which required me to jump through hoops to run my EEEPC 701 SD. So I went with a more modern Linux Debian Distribution (operating system,distro)


@antiX1:~$ inxi
CPU~Single core Intel Celeron M (-UP-) clocked at 897.802 Mhz Kernel~2.6.38-3.dmz.1-liquorix-686 i686 Up~1:52 Mem~241.3/1000.6MB HDD~8.1GB(-) Procs~99 Client~Shell inxi~1.7.13-8 
harry@antiX1:~$ inxi -F
System:    Host antiX1 Kernel 2.6.38-3.dmz.1-liquorix-686 i686 (32 bit)
          Desktop IceWM 1.3.7 Distro antiX-M8.5-686-update 27 July 2010
Machine:  System ASUSTeK (portable) product 701SD version 0303
          Mobo ASUSTeK model 701SD version x.xx Bios American Megatrends version 0303 date 07/23/2008
CPU:      Single core Intel Celeron M (-UP-) cache 512 KB flags (nx sse sse2) clocked at 897.802 MHz
Graphics:  Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller
          X.Org 1.9.5 driver intel Resolution 800x480@60.0hz
          GLX Renderer Mesa DRI Intel 915GM GEM 20100330 DEVELOPMENT x86/MMX/SSE2 GLX Version 1.4 Mesa 7.10
Audio:    Card Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller driver HDA Intel
          Sound: Advanced Linux Sound Architecture v: 1.0.23
Network:  Card-1 Realtek RTL8187SE Wireless LAN Controller driver r8180
          IF: wlan0 state: up mac:
          Card-2 Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet driver ATL1E
          IF: eth0 state: down speed: 65535 Mbps duplex: full mac:
Drives:    HDD Total Size: 8.1GB (-) 1: /dev/sda ASUS 8.1GB
Partition: ID:/ size: 7.4G used: 3.5G (50%) fs: rootfs
Sensors:  System Temperatures: cpu: 53.0C mobo: N/A
          Fan Speeds (in rpm): cpu: 1390
Info:      Processes 99 Uptime 1:52 Memory 241.6/1000.6MB Client Shell inxi 1.7.13-8

newbieShannon 07-06-2011 06:43 PM

Thank you all very much for your help! I did the F2 install and upgraded to Firefox 3.16(ish) and will let it stay there. I truly appreciate the time you all took out of your busy lives to provide advice and guidance!

All times are GMT -5. The time now is 04:22 AM.