-   Linux - Newbie (
-   -   Problem installing Debian Lenny 5.0..... (

raisun 08-17-2009 03:34 AM

Problem installing Debian Lenny 5.0.....
I dont know whether this is an unique problem........I am new to linux.....and also new to Debian Lenny 5.0

I was trying to install Lenny 5.0 in my system which already has Windows XP in it. But now it started developing problems....

Let me explain in steps.....what i did.......

1. I have a sony dvd rom....which i am using for installing Lenny.

2. The dvd rom (IDE) is connected as a secondary master on my

3. Unfortunately the dvd rom wont read the installation DVD.

4. Now i used another LG DVD writer (SCSI) for installation.

5. The SCSI is connected as a Third Master.

6. Now i can boot from the dvd and the installation starts.....but
when it reaches the DETECT CD ROM and MOUNT it does not detect the
SCSI drive but it checks for the IDE drive.

7. I tried by removing the IDE drive connection from the motherboard But it shows the message " NO CD
ROM DETECTED". even when the SCSI is still connected.

8. When I connect the IDE Drive it shows " NO CD IN THE
DRIVE"...eventhough the installation cd is in the SCSI drive.

9. Now i cannot connect the SCSI drive as secondary Both
my primary and secondary are IDE.

10. I do not know whether this is a Hardware problem or Linux

* Is there any way i can make Linux detect the SCSI drive.....without setting it as the secondary.

* Is it possible that Lenny has a default settings of detecting drives in secondary master.

* I am new to please help...and if possible give a

It did ask for the location for the installation CD...
It did ask for the device file to be mounted on....or something similar to that......

it had the path.... /dev/cdrom

now i know cdrom is not correct....but i hav to specify the file name.......i.e /dev/filename...

but the problem is i dont know the device file name...........

and i dont know hw to find it....

i did try..... " ls /dev "

but i did not find anything useful....

Can you help me with this....

Thanking you for your time...


mag1strate 08-17-2009 07:59 PM

I'm pretty sure it is a hardware problem, try connecting the DVD writer to a different port.
Maybe Debian is trying to work off a different connector but I think that is unlikely. I'll look around and keep you posted.

mag1strate 08-17-2009 11:05 PM

Most of the information I found doesn't seem to help. I would try to install Debian with a USB port instead, it is more efficient. But before you install go into the motherboard options and make it boot from USB or it will go straight to your DVD writer or hard-drive.

raisun 08-20-2009 02:19 AM

Thanx for replying....i will surely try out your suggestion.
I have never tried to install using an USB....

Guess i will have to check it up....

thanx again

mf93 08-20-2009 07:33 PM

are you connecting the dvdrom device through usb or some other external plug? it won't be mounted as dev/cdrom it will be mounted as /dev/sdxy where x is a letter between a and c and y is a number between 1-6 usually sda- mounted devices are Internal drives sdb's and sdc's are external i would recommend setting teh device to find as /dev/sdb1 and if that doesnt work try /dev/sdb2 and if not either of those it will be /dev/sdc1 or /dev/sdc2 so keep me posted...

raisun 08-24-2009 02:16 AM

Thank you i will keep you posted........

All times are GMT -5. The time now is 12:30 PM.