LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problem installing Apache Modules (https://www.linuxquestions.org/questions/linux-newbie-8/problem-installing-apache-modules-387823/)

Vantasticman777 11-30-2005 02:35 AM

Problem installing Apache Modules
 
I get the following error message when installing any Apache modules:

Can't exec "/usr/bin/apr-config": No such file or directory at /usr/sbin/apxs line 49.
Use of uninitialized value in scalar chomp at /usr/sbin/apxs line 54.
apxs:Error: /usr/bin/apr-config not found!.

I searched and could not find any apr-config file. Where do I get a correct apr-config file?

My stuff: CentOS 3.5 & Apache 2.0.54

Thanks,
Van

rylan76 11-30-2005 03:43 AM

Did you compile apache yourself or get it from somewhere else?

As far as I know you specifically need to enable APXS support when compiling apache - if you got a binary distribution of apache, it might be that whoever you sourced it from did not include APXS support when configuring and compiling apache...

You best approach (if this isn't what you've done already) might be to download a source archive of the latest apache version (I think it is 2.0.54 which you already have) and compile it yourself.

It's not that hard, try the following steps:

1. Get the source archive.
2. Unbzip / ungzip it with either

tar zxvf archive.tar.gz

if you got a .gz archive, or

bunzip2 archive.tar.bz2
tar xvf archive.tar

if you got a .bz2 archive.

3. Change into the resulting directory.

4. In the apache source directory, type

./configure --help | grep apxs

5. If you just get your terminal prompt again, with no info about an apxs entry also try

./configure --help | grep APXS

6. This will show you what configuration option to set to specifically enable APXS, if any.

7. Now, once you have the needed parameter do

./configure --with-apxs

if applicable.

8. Wait untilt he configure completes, then do

make

9. Wait again. When done, and you have your terminal prompt back, become superuser by typing

su

end entering your password.
a
10. Type

make install

11. This will then install apache.

Try and install a module again, most likely you will now have APXS support for the modules you need to install...

Regards,

Vantasticman777 12-01-2005 01:14 AM

Thanks, I will give it a shot the next few days. My host installed the OS and Apache on my VPS account. There was not a lot of documentation on APXS available.

Van


All times are GMT -5. The time now is 08:51 AM.