LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-05-2011, 03:51 PM   #1
theashishmishra
Member
 
Registered: Aug 2011
Location: Bangalore
Distribution: WIndows 7,Fedora
Posts: 43

Rep: Reputation: Disabled
Unhappy Problem in updating the system using yum


I have installed Fedora 16 today but when I was trying to update my system using the command
yum update

It showed this error message in the end
Processing Dependency: checkpolicy >= 2.1.6-2 for package: selinux-policy-3.10.0-64.fc16.noarch
--> Finished Dependency Resolution
Error: Package: selinux-policy-3.10.0-64.fc16.noarch (updates-testing)
Requires: checkpolicy >= 2.1.6-2
Installed: checkpolicy-2.1.3-1.2.fc16.i686 (@anaconda-0)
checkpolicy = 2.1.3-1.2.fc16
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

What could be the solution?
Thanks
 
Old 12-05-2011, 04:00 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650
Why do you have updates-testing enabled ?
 
Old 12-05-2011, 04:04 PM   #3
theashishmishra
Member
 
Registered: Aug 2011
Location: Bangalore
Distribution: WIndows 7,Fedora
Posts: 43

Original Poster
Rep: Reputation: Disabled
I have not enabled anything by myself..Its default..I have installed Fedora16 few hours ago..Its Beta version I guess
 
Old 12-05-2011, 04:12 PM   #4
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650
The updates-testing repo shouldn't be enabled by default, you can disable it by editing /etc/yum.repos.d/fedora-updates-testing.repo and changing all the 'enabled=1' to 'enabled=0'. If you then retry the 'yum update' you should be ok.
 
Old 12-05-2011, 04:18 PM   #5
theashishmishra
Member
 
Registered: Aug 2011
Location: Bangalore
Distribution: WIndows 7,Fedora
Posts: 43

Original Poster
Rep: Reputation: Disabled
Thanks a lot..It worked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC6 Yum Error When Updating System jc_cpu Linux - Software 7 05-03-2008 01:35 PM
yum repository problem after system upgrade xpucto Fedora 2 11-24-2007 06:27 AM
yum updating problem bonus_uk Linux - Software 3 10-01-2005 10:06 PM
9.3 updating system config problem aots_g4_rules SUSE / openSUSE 4 08-06-2005 05:23 PM
Updating system with yum broke Openoffice.org Jamo Fedora 3 06-15-2005 04:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration