LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-25-2005, 02:56 PM   #1
achal
LQ Newbie
 
Registered: Jan 2005
Location: indore
Distribution: fedora
Posts: 25

Rep: Reputation: 15
problem in startx


dear friends
iam insatalling slackware 10.1 on a system.. after installing i tried to do entervalues to xorg.conf file by
#xorgconfig in order to start kde session
everything is ok but when it comes to entering onboard graphic card detail i cant enter it
it has no entry for intel i845 motherboard with16mb graphic card memory
it only shows intel i810 and intel i710
i dont know comaptibity
but when i chose any of the above two
and try to startx by
#startx
there is fatal error mesage
that screen not found
kindly help me to start the kde session
or tell me how to move to gnome desktop
anyone will help
 
Old 08-25-2005, 03:00 PM   #2
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
You should use i810
i810 - Intel 810 motherboards (i810, i810-dc100, i810e, i815, i830, i845, i855, i865)
 
Old 08-25-2005, 03:02 PM   #3
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 46
hi there,
my guees is that "screens not found" is somehow related to sync ranges of your monitor.
your card should word fine with "i810"...
post your xorg.conf and let's see what is happening...
regards
slackie1000

[edit] beated by bosewicht. i need to learn how to type faster...

Last edited by slackie1000; 08-25-2005 at 03:03 PM.
 
Old 08-25-2005, 05:01 PM   #4
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Rep: Reputation: 32
Yes, the problem is not with the driver. i810 is the correct one.
I also have an Intel 845 motherboard and i810 works just fine. The problem is somewhere else.

Long time back I also had such a problem. I don't remember it now.
Post the exact error message you are getting. I think it gives one more error message first and then says no screens found. Also post the contents of your xorg.conf file.

I'll agree with Slackie1000 that the problem may be due to the sync ranges of your monitor.
Look up your monitor manual to see what sync ranges it offers.

For the time being do this : run xorgconfig as root select i810 as the driver and choose the most generic of settings for your monitor and other things.
Post whatever you get.
Hope this helps.

Last edited by koodoo; 08-25-2005 at 05:03 PM.
 
Old 08-28-2005, 02:28 AM   #5
achal
LQ Newbie
 
Registered: Jan 2005
Location: indore
Distribution: fedora
Posts: 25

Original Poster
Rep: Reputation: 15
dear friends
thanks for ur inputs
my problem has been solved
as u said it was due to graphics card and it was true
though i have intel i845 chipset the graphics card is of sis
[generic]
selecting that the the x window started
thank u for ur help
 
Old 08-28-2005, 06:59 AM   #6
slackie1000
Senior Member
 
Registered: Dec 2003
Location: Brasil
Distribution: Arch
Posts: 1,037

Rep: Reputation: 46
hi there,
glad to help and happy birthday btw...
regards,
slackie1000
 
Old 08-28-2005, 08:00 AM   #7
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
Re: problem in startx

Quote:
Originally posted by achal
kindly help me to start the kde session
or tell me how to move to gnome desktop
anyone will help
hello there,
to move to some other desktops ( assuming your init =3 in /etc/fstab ) from the konsole type "xwmconfig" there.
There will appear a "menu" for selecting the window managers from the various ones include the "kde".

regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
startx problem Neomorpheus Debian 4 02-10-2005 07:17 AM
Bug / Xwindows / startx : xinit works but startx crash www.rzr.free.fr Linux - Software 4 10-17-2004 08:06 AM
StartX Problem... X-Rated Slackware 3 09-24-2004 07:11 PM
Problem during startx fransemail Linux - Software 3 07-24-2004 01:11 PM
startx problem dark_light Linux - General 4 05-03-2003 09:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration