LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Problem in setting up radius server (https://www.linuxquestions.org/questions/linux-newbie-8/problem-in-setting-up-radius-server-836471/)

champs1234 10-06-2010 02:49 AM

Problem in setting up radius server
 
Iam setting up a radius server in my local network , i have installed free radius for this. The users will be connected to server throgh pppoe connection. I have configured everything and everything seems to works properly except these 2 .

1) If a connecttion gets broken up then radius server is npt able to detect that connection is gone and the user is not able to connect againg for 30 -35 mins as the multiple logins are disable.

To make it more clear, suppose a person is connected to my server through lan but du to some reason the lan network was down for 5 to 10 which will result in disconnection in the client side but as server is up and runnig the server is not able to recgnize that the user is ang and mark that user as logged out.

Please help as iam on a wireless network such cases occur very frequently and i need to solve this problem.

2) whenever i gives max-mb limit of a user in database b/w 3 to 4 gb then that particular user is not able to connect to the server. But when i change to 2gb or greater than 5 gb it works properly.

Please help me..


Thanks

champs1234 10-09-2010 11:58 PM

please somebody help....

sohail0399 10-10-2010 10:06 AM

I have seen this kind of issue in my ISP setup. But the case is different, in ISP there is RAS (Remote access server) between user and RADIUS but in this case if the user is disconnected RAS send request to RADIUS.


For this I dont know you have configured it as AAA Framework or only RADIUS, if it is AAA Framework then there is accounting going on. then set the accounting packet receiving time to 5 minuts or less, for this if RADIUS does not receive the accounting packet, it will remove its session and user can be able to reconect.


I did not work in Free RADIUS,so i dont know about it setting and configuration and documentation.
Free RADIUS is good soution,

hope you will find a good solution.

champs1234 10-12-2010 01:22 PM

Thanx for reply, but iam still clueless what to do...

jcmlq 10-12-2010 01:54 PM

Is disabling the simultaneous-user check an option?

champs1234 10-13-2010 07:28 AM

no its an compulsion, i have to disable simultaneous use...

outsourcingrbts 10-13-2010 07:51 AM

H!,
can u tell me how u solve this problem..

champs1234 10-13-2010 08:11 AM

Problem is still unsolved. Still searching for the solution. If you get 1 please do help me also and if get one then will do the same..

TB0ne 10-13-2010 08:47 AM

Quote:

Originally Posted by champs1234 (Post 4125990)
Problem is still unsolved. Still searching for the solution. If you get 1 please do help me also and if get one then will do the same..

Spell your words out...that text-speak garbage is against LQ rules.

And again, did you check the Freeradius pages/wiki??
http://freeradius.org/radiusd/doc/Simultaneous-Use

From the bottom of that page:
Quote:

6. PROBLEMS WITH DROPPED CONNECTIONS
Our PM3, with 2 ISDN-30 lines coming into it, had the habit of sometimes
dropping connections. In a few cases, the portmaster thought the session was still alive so if the user tried to login again, he or she was denied access. In our case, this problem was caused by a bad PRI line from the phone company.

We tried to compensate this by setting the Idle-Timeout to 15 minutes. That way, even if a user did get locked out the portmaster would clear the rogue session within 15 minutes and the user could login again.
If you don't log out, the connection stays active. So set the idle-timeout lower, or allow the user(s) more than one active connection.

champs1234 10-13-2010 09:10 AM

Sorry..

And i have already placed Idle-Timeout:=15 in my radgroupreply table, but still no success. maybe i have to write it in some other table or file, if that's the case then please do let me know.

champs1234 10-23-2010 01:41 AM

Please please please some one answer this, iam still searching for an answer

TB0ne 10-23-2010 11:19 AM

Quote:

Originally Posted by champs1234 (Post 4136527)
Please please please some one answer this, iam still searching for an answer

Quit posting follow ups to your own questions, and begging for help.

As with your other thread, you were given the answer, but can't seem to understand it. Read the page you were given. If things aren't working according to the documention FROM THE PEOPLE WHO WROTE THE PROGRAM, then you've done something wrong. Go back, read the instructions again, and follow them carefully.


All times are GMT -5. The time now is 04:46 AM.