LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   problem in replacing hardisk raid5 array (https://www.linuxquestions.org/questions/linux-newbie-8/problem-in-replacing-hardisk-raid5-array-81562/)

slack66 08-13-2003 04:13 AM

problem in replacing hardisk raid5 array
 
hello:) iam running slackware 9 and have 4 hd all ide drive,i create a disk array "raid5" hdb1,hdc1,hdd1 then to test it i run raidstop and raidstart...seem are all working fine.now i try to simulate a hardisk failure.i try to run a command:
#raidsetfaulty /dev/hdd1
#lsraid -a /dev/md0
the status of hdd1 failed then:
#raidhotremove /dev/md0 /dev/hdd1
#lsraid -a /dev/md0
now there is no hdd1 anymore status missing
i try replacing it with a new hardisk then i run:
#raidhotadd /dev/md0 /dev/hdd1
and nothing happened and no recovery has done???
i try to reboot but the same no hdd1 in the array went i run
cat /proc/mdstat.... it say "3/2" only 2 device in array and one is missing (hdd1). iam so confused....in the manual it seem to easy to replace a hardisk in array,i followed step by step but it didnt work .what seem to be my mistake??? iam so confuse pls help me:(


All times are GMT -5. The time now is 10:13 PM.