-   Linux - Newbie (
-   -   problem in mounting cdrom(audio files running but not reading data files) (

amit_usual 12-26-2007 05:11 AM

problem in mounting cdrom(audio files running but not reading data files)
(using ubuntu fiesty fawn)
I wouldn't exactly say that the problem i am having is in mounting the cd.
I am able to mount the cd and i am able to play audio files but i am not able to read Data files . Please tell me what could be the reason for this?

bigrigdriver 12-26-2007 06:37 AM

What command do you use to mount the data cd?

Did you make the data cd yourself? If so, what command did you use to make the cd?

roy_lt_69 12-26-2007 08:39 PM

Also, what does your /etc/fstab look like?

amit_usual 12-27-2007 06:52 AM

well i use mount /media/cdrom.. (in a general scenario it should be mounted automatically)
yes i made the data disk myself , i have read from it earlier and also checked it out on some other machine ...
--my /etc/fstab looks like:

# /etc/fstab: static file system information.
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda1
UUID=ff89e892-8820-4513-b830-8da56e05585d / ext3 defaults,errors=remount-ro 0 1
# /dev/sda5
UUID=962ddb3b-59d9-4e34-b5a7-ad7ca0a0193d none swap sw 0 0
#/dev/hdb /media/cdrom0 udf,iso9660 user,noauto 0

--my /etc/mtab looks like

/dev/hda1 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
/sys /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
procbususb /proc/bus/usb usbfs rw 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
lrm /lib/modules/2.6.20-16-generic/volatile tmpfs rw 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0

jschiwal 12-27-2007 06:55 AM

According to your mtab listing, the cdrom is not mounted. So you are reading the contents of the directory instead, which is empty.

amit_usual 12-27-2007 07:53 AM

--for an audio disk my mount gives the following result

/dev/hda1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.20-16-generic/volatile type tmpfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/hdb on /media/mp 3 type iso9660 (ro,nosuid,nodev,uid=1000,utf8)

obviously different from /etc/mtab when a data disk is inserted , how is that possible?? i don't get it...

roy_lt_69 12-27-2007 11:21 PM

Add an entry to /etc/fstab for your cd drive:
/dev/hdb /media/cdrom iso9660 defaults,users,ro,noauto 0 0

amit_usual 12-29-2007 05:52 AM

well it worked but still i have a few questions
1. why should one give noauto??
2. well it is dvd reader actually and i have a few dvds it is still not able to read...
i tried mounting it by specifying udf file system but still it was no use ... what all filesystem types are possible on dvds and how should i specify more than one file system
in /etc/fstab

All times are GMT -5. The time now is 04:13 PM.