-   Linux - Newbie (
-   -   Problem getting Jack Audio Connection Kit to started. (

miltblue 03-29-2007 04:33 PM

Problem getting Jack Audio Connection Kit to started.
I have spent several days now trying to get the Jack Audio Connection Kit up and running in Fedora Core 6. I have tried Installing both Jack and Qjackctl from rpm and using Yum. The results are the same. The machine with Fedora Core 6 install is as follows:
Dell Optiplex GX200 - P3 - 900MHZ 512m Ram
Soundcards Intel Onboard - 82801AA AC'97 Audio
PCI - Creative Labs, SoundBalaster Live! EMU10k1
I get the same error using either card as the interface. Jack appears to start when I start it using Qjackctl, but it always fails with the following error - could not connect to Jack Server as Client.
It then trys to restart again and continues to do so. If I start Jack from the command line using jackd -d alsa -d hw:0 the server appears to run with no errors. But when I start Rosegarden it tells me theres no audio. I have Googled the error and searched this and other forums but have not been able to find the answer to this problem, hardware or software wise. Below is the output from Qjackctl:
16:19:00.202 Patchbay deactivated.
16:19:00.230 Statistics reset.
16:19:00.263 Startup script...
16:19:00.263 artsshell -q terminate
16:19:00.449 MIDI connection graph change.
16:19:00.723 Startup script terminated with exit status=256.
16:19:00.724 JACK is starting...
16:19:00.724 jackd -v -R -u -dalsa -r44100 -p1024 -n2 -D -Chw:0 -Phw:0 -I46 -O46
16:19:00.736 JACK was started with PID=25361 (0x6311).
getting driver descriptor from /usr/local/lib/jack/
getting driver descriptor from /usr/local/lib/jack/
getting driver descriptor from /usr/local/lib/jack/
jackd 0.102.20
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
server `default' registered
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
16:19:00.938 MIDI connection change.
configuring for 44100Hz, period = 1024 frames, buffer = 2 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 2 periods for playback
25361 waiting for signals
registered builtin port type 32 bit float mono audio
registered builtin port type 8 bit raw midi
clock source = system clock via gettimeofday
new client: alsa_pcm, id = 1 type 1 @ 0x920ff68 fd = -1
new buffer size 1024
registered port alsa_pcm:capture_1, offset = 4096
registered port alsa_pcm:capture_2, offset = 8192
registered port alsa_pcm:playback_1, offset = 0
registered port alsa_pcm:playback_2, offset = 0
++ jack_rechain_graph():
client alsa_pcm: internal client, execution_order=0.
-- jack_rechain_graph()
load = 0.0904 max usecs: 42.000, spare = 23177.000
16:19:02.960 Could not connect to JACK server as client. Please check the messages window for more info.
load = 0.2132 max usecs: 78.000, spare = 23141.000
load = 0.1992 max usecs: 43.000, spare = 23176.000
load = 0.2094 max usecs: 51.000, spare = 23168.000
load = 0.2899 max usecs: 86.000, spare = 23133.000
load = 0.2634 max usecs: 55.000, spare = 23164.000
16:19:08.384 JACK is stopping...
jack main caught signal 15
starting server engine shutdown
stopping driver
unloading driver
freeing shared port segments
stopping server thread
stopping watchdog thread
last xrun delay: 0.000 usecs
max delay reported by backend: 355.000 usecs
freeing engine shared memory
max usecs: 86.000, engine deleted
no message buffer overruns
cleaning up shared memory
cleaning up files
unregistering server `default'
16:19:08.891 JACK was stopped successfully.
16:19:08.897 Post-shutdown script...
16:19:08.903 killall jackd
jackd: no process killed
16:19:09.162 Post-shutdown script terminated with exit status=256.
Though I just recently decided to add a Linux box to my existing Microsoft network I am not a novice to Linux or DAW's. I am a certified MCSE and have worked on many Unix / Windows implementations for quite some time. Had no problems getting core 5 up and running in the network and upgrading to core 6. Wanted to add the Linux both to my existing Midi setup, but been stuck for days now. I would appreciate any help.
Thanks Much in advance.

All times are GMT -5. The time now is 06:09 AM.