-   Linux - Newbie (
-   -   problem falling back to console (

systelm 04-15-2006 01:56 PM

problem falling back to console
i'm under slackware 10.2 and i have a problem falling back to a text console after starting kdm. when i try pressing ALT+CTRL+Fx, the screen blanks and i can't go back to kdm by going to any other tty; the screen just flicks as it would before going fom console to kdm but it just stays black. I've also tried with xdm with same results. Also when i poweroff the screen goes blank and i don't know when to manually shutdown. this is a real bummer, as i have to reboot every time i want to fall back to text. any help would be useful. i THINK it might be because of my video driver, whitch might also explain why my video playback on xine is so slow (but it's so fun with aaxine :p) .
thanks for future posting.


pnellesen 04-15-2006 05:57 PM

Just verifying: You've tried "ALT+CTL+F6" to get to the console, and then "ALT+CTRL+F7" to get back to GUI? (Just checking, cause I sometimes forget that I've got my system set to runlevel 4 in "/etc/inittab"). If this is something completely different, my apologies.

systelm 04-17-2006 03:46 AM

i'm not sure if i've tried ALT+CTRL+F6, but i don't think it'll work. i'll try it when i get home anyway. but when I use ~F2 at least, it's impossible to get me back to a useable interface, text or GUI. but the funny thing is that i CAN get onto a text console by 'blindly' logging in on any tty (except fo the one that i actually started kdm on (for obvious reasons)) and giving restart or poweroff. I'm sure it must be some harware fault, but i can''t be sure, and even so, i don't, know how to fix it... what's this about runlevels? I've heard of it before, but haven't looked it up. Is there any info on it in the manpages (or if it's not too much trouble, could you please write a short basic definition of the different runlevels. thanks.) bare in mind that i have not changed the config for my ttys (and don't know how...) from the original config that came with Slackware 10.2 and since you have the same distro, the config must be the same.
Thanks for the help.


All times are GMT -5. The time now is 01:54 AM.