-   Linux - Newbie (
-   -   problem building and installing rpm from ndiswrapper source (

steveman2000 10-21-2005 04:10 PM

problem building and installing rpm from ndiswrapper source

I'm a newbie whos (hopefully) near the end of getting my wireless PCI card supported using ndiswrapper. I so far have got the ndiswrapper saying I have a valid driver and that my card is there.

HOWEVER my next obstacle is that modprobe ndiswrapper fails:

Command failed: /sbin/modprobe ndiswrapper

FATAL: Module ndiswrapper not found

I'm assuming I need to build and then install an rpm of ndiswrapper to fix it. I've been through the process fo doing this by going to the source (driver) directory typing "make makedist" which works fine and then after switching to admin typing "make" in the source directory. This claims that it cant find the kernel sources and asks to specify the dir of it. This has lost me please help!!!

jschiwal 10-21-2005 05:13 PM

Building a RPM would just make it more convenient to reinstall the same thing in the future. It might have some edits to the spec file if you are starting with a ndiswrapper-<version>.src.rpm file so that the RPM file you end up with works better on your system.

It is more likely that you need to download a newer version of ndiswrapper and build it from source.

Also, there are an ndiswrapper option to modify one of the configuration files that you may need to do. Run "ndiswrapper --help" for that information.

Lastly try running "ldconfig" as root. It is possible that the location of the libraries that ndiswrapper uses are not being searched by the loader. Sometimes an installation will not do this automatically. This is performed periodically by a cron job, but it is worth a try.

steveman2000 10-21-2005 05:19 PM


The one i downloaded is the latest as far as I know. As you will se in another post it seems that I now have a problem building it as it seems the link for the source of the kernel isn't right (which i think is pretty muhc what u said anyway isn't it?).

cheers for your help btw!

kilgoretrout 10-21-2005 06:49 PM

You probably don't have your kernel source code installed; it's not installed by default. To check, open a console and run:

$ rpm | grep kernel

Post the output here. I believe the package is called kernel-source or kernel-sourcecode or something like that in rh/fedora. You only need the source code if you are compiling a kernel or a kernel module, like ndiswrapper. Since the kernel source can be pretty big(50MB), it is usually not included/installed by default.
Compiling ndiswrapper from source will probably fix your problem. I assume the previous install of ndiwrapper was from an rpm. The rpm probably was compiled on a different kernel than the one you are using; I had the same thing happen to me with identical symptoms. Compiling from source fixed it.

steveman2000 10-21-2005 07:40 PM


I have another problem now. After having downloaded teh source from internet and installing it I soon realised that the link between two of the directories didnt fit the right format. So i changed it and then ran the build rpm thing like the ndiswrapper install thing says. The first one i tried seemed to do absolutely nothing. So I tried the rpmbuild one instead and that wrote four rpm files which i installed with no problems. but then when I ran the "modprobe ndiswrapper" it now comes up with an error message (check out the quote below):

What I installed (which was made):

The error when I ran "modprobe ndiswrapper":

FATAL: Error inserting ndiswrapper (/lib/modules/2.6.13-1.1526_FC4.stk16smp/misc/ndiswrapper.ko): Invalid module format

...having just looked it up it seems this is down to kernel/ndiswrapper compilation problems. I downloaded a pre-compiled kernel, installed it. Then went back to the same website and got the source code version, then compiled ndiswrapper with that.

This is where i got the kernel from:

The one i downloaded and then installed is: 2.6.13-1.1526_FC4smp
and the one i downloaded, installed and before having compiled ndiswrapper was: Development (of the same one).

I think im gonna try downloading and installing 2.6.13-1.1526_FC4 becuase i have no idea what the spm stands for!

btw where is the source located?.... there seem to be two dirs the tutorials are always on about.

cheers again!

jschiwal 10-23-2005 08:01 PM

SMP is for a computer that has more than one processor chip. The kernel and drivers have to include things like spin-locks, and many operations have to be done "atomically" so that one processor doesn't partially change something that another processor retrieves.

By the source, I meant the source tarball from the sourceforge project site. Although, the RedHat source rpm may be recent enough.

If you ran "rpmbuild -bi", to install from source, on more than one .src.rpm, I'm wondering if that could cause a problem, having multiple ndiswrapper versions existing in the kernel source at the same time.

All times are GMT -5. The time now is 08:24 AM.