-   Linux - Newbie (
-   -   Problem booting Puppy Linux in Virtualbox (

JohanB 11-29-2010 04:38 AM

Problem booting Puppy Linux in Virtualbox
Hey everybody,

In order for me to get started with Linux, I downloaded & installed Virtualbox (V3.2.10) on my WinXP machine, and downloaded the Puppy Linux image from as per

When I start up the VM, I get a GRUB menu allowing me to boot

Linux (on /dev/hda1)
Install GRUB to floppy disk (on /dev/fd0)
Install GRUB to Linux partition (on /dev/hda1)
I tried the first option, which results in

Booting 'Linux (on /dev/hda1)'

root (hd0, 0)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz root=/dev/hda1 ro vga=normal
[Linux-bzImage, setup=0x1c00, size=0x1b4cd8]

Uncompressing Linux... Ok, booting the kernel.
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0, 0)
I then tried installing GRUB to the Linux partition, which seems to work, but when I try to boot Linux, I get the same problem.

Any suggestions?

Thanks in advance.


JohanB 11-29-2010 06:11 AM

OK, I solved it:
Uninstalled VirtualBox and installed V2.04, and everything works like a charm. Would it be a good idea to go up in version numbers until I find out where it breaks?

I hope to use this setup to prepare for LPIC1, so expect more braindead question from me in the near future.


jefro 11-29-2010 03:54 PM

Makes no sense to me why the latest doesn't work. It should have.

JohanB 12-01-2010 01:22 AM


I haven't lurked here long enough to know what the general feeling regarding Oracle is, so I apologize in advance if I'm starting a flame war. Having said that, there has been reports that VirtualBox has been getting buggier since Oracle's take-over of Sun.

The article is hardly scientific, but my experience certainly corroborates it in some small way. I am still trying to find the time and motivation to find out precisely where VBox starts breaking.


Soadyheid 12-01-2010 01:02 PM

I'm confused as to why you were playing around with Grub! :scratch:

I've only played with Virtualbox and have V3.2.10 sitting on an Ubuntu host. (V3.2.10 appears to acknowledge USB drives where older versions don't!) I've only got a single instance of Mint 7 as a Virtual system loaded but it works fine. It didn't have any mention of Grub though? Assuming I had multiple VMs loaded within VirtualBox, I'd just have to select each one and hit "Start" to run them up.

Nope? Grub? you've got me foxed! :confused:

Is VirtualBox on XP somehow different?

Play Bonny! :hattip:

JohanB 12-02-2010 01:38 AM

I assume GRUB was loaded on the virtual appliance when it was created. If you like, you can download the image I played with from the link in the first post in the thread - its only about 70MB if memory serves. I would actually appreciate it if somebody tried to reproduce what I saw.


Soadyheid 12-02-2010 06:45 PM

Ah.... I can't quite remember how I loaded up my Mint virtual machine. I think I just hit "New" and pointed at either a live CD or an ISO image I'd downloaded - probably the former. Grub may be lurking under the bonnet (hood) but I can't remember it being mentioned during the install. Interesting...

Play Bonny! :hattip:

Fritzr 08-22-2011 01:09 AM

Puppy Linux on Oracle Virtual Box
Wary Puppy 5.1.3 installs correctly on Oracle Virtual Box 4.1.1

Use a LiveCD ISO file. Insert it in the VM CD drive and alt-ctrl-del the VM from the VM menu bar.

X windows is not available with Wary Puppy 5.1.3
VBox requires an S3 Trio or VESA 2.0 video driver.
Puppy command line appears to work corrrectly. Not tested beyond verifying that it was a working copy of Puppy as I am trying for a VM with X Windows that will allow me to use internet on host and guest simultaneously.

VBox hijacks my Belkin Wireless adapter preventing the Host OS from using it.
Just completed a Puppy install on VMWare Player.

Under VMWare Player Wary Puppy 5.1.3 installs with no problems (LiveCD again) shares the network connection with the host and runs X Windows (using XVESA at the moment)

Reviving an old thread, but I would have been very happy to have this info a few days ago :)

All times are GMT -5. The time now is 02:34 PM.