LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-09-2003, 06:28 PM   #1
thegeekster
Member
 
Registered: Dec 2003
Location: USA (Pacific coast)
Distribution: Vector 5.8-SOHO, FreeBSD 6.2
Posts: 513

Rep: Reputation: 34
problem accessing fat drive as a user


Hi folks

Seems I can't access my FAT32 Windows' partitions in Linux as a user (get an "Access denied" error), yet I can read and write as root. I've tried changing the permissions to the directories they're mounted at, but when remounting the partitions the permissions change back to their original permissions while mounted and yet the permissions for the directories will revert back to the changes I've made when unmounted.

I've also tried to change the mount options in fstab with 'nosuid' and 'users', without success.

Here are the original entries in fstab:
Code:
/dev/hda1        /Windows/0-1_WIN vfat        defaults         1   0
/dev/hdb5        /Windows/1-2_DATA vfat       defaults         1   0
/dev/hdb6        /Windows/1-3_STORE vfat      defaults         1   0
Any help much appreciated.......



BTW: I'm using Slack 9.1
 
Old 12-09-2003, 06:33 PM   #2
ToniT
Senior Member
 
Registered: Oct 2003
Location: Zurich, Switzerland
Distribution: Debian/unstable
Posts: 1,357

Rep: Reputation: 47
Change the 'defaults' field to form 'defaults,user,noauto' and mount the drive as an user (unmount it as root first).
Something like
Code:
/dev/hda1        /Windows/0-1_WIN vfat        defaults,user,noauto         1   0
.
 
Old 12-09-2003, 06:46 PM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 16,430

Rep: Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938Reputation: 1938
BTW a very commonly asked question, change fstab entry to:

/dev/hda1 /windows/0-1_WIN vfat users, umask=000 0 0

See man pages for mount and fstab for additional help with options.

Last edited by michaelk; 12-09-2003 at 06:47 PM.
 
Old 12-09-2003, 07:01 PM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
For vfat mounts there is something you may want to try. If you want permissions on a drive to go to a particular group or user, add uid=xxx or gid=xxx to the options where the xxx represent the group or user ID numbers. For ext2/3 partitions, just use the chown command.
 
Old 12-09-2003, 08:52 PM   #5
thegeekster
Member
 
Registered: Dec 2003
Location: USA (Pacific coast)
Distribution: Vector 5.8-SOHO, FreeBSD 6.2
Posts: 513

Original Poster
Rep: Reputation: 34
Thanx for the quick replies, folks

I followed michaelk's advice using the umask option, and was playing around with it to see if I could set some permissions on those partitions since umask=000 removes all permissions. But I see that jschiwal has answered that for me......

I also had to reboot the computer for the changes to take effect since the 'mount -a' command didn't change the permissions.

Thanx for all the help!
 
Old 12-09-2003, 09:59 PM   #6
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Quote:
I also had to reboot the computer for the changes to take effect since the 'mount -a' command didn't change the permissions.
Use 'mount -a -o remount'. Or just unmount the partition & mount again.
 
Old 12-09-2003, 11:14 PM   #7
thegeekster
Member
 
Registered: Dec 2003
Location: USA (Pacific coast)
Distribution: Vector 5.8-SOHO, FreeBSD 6.2
Posts: 513

Original Poster
Rep: Reputation: 34
Quote:
Use 'mount -a -o remount'......
Thanx. I'll have to remember that one
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Accessing Fat drives as User fantacmet Linux - General 5 02-19-2004 02:18 AM
Accessing fat-c from Gnome thom Slackware 11 01-13-2004 01:38 PM
Accessing FAT partitions? fusion1911 Slackware 8 11-16-2003 02:46 PM
fat drive permissions problem llimllib Linux - General 2 07-18-2003 08:51 PM
Mandrake 9.0: Accessing partition on windows drive(FAT) face_master Linux - Distributions 3 01-18-2003 10:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration