LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Printing pdfs (https://www.linuxquestions.org/questions/linux-newbie-8/printing-pdfs-4175612336/)

AlaricWood 08-21-2017 12:03 AM

Printing pdfs
 
Here I am again. Custom computer with intel i7 and 8gb ram. I installed Debian 9 and had problems but it automatically installed my Brother HL-2240D. We eventually worked out that my installation disk was corrupt. A re-install solved other problems but did not install the printer.

Previous versions of Debian shewed an entry for printers on the control panel and it was possible to install and manage printers from it. 9 does not have such an entry. Searching the menu for printers lists installed printers but does not allow any actions.

Using the Brother web site I have installed HL-2440D and it works for ordinary files but not pdfs. I now have about five jobs stalled and cannot remove them though I will do so from the command line. Past installations I think I used 1250 as recommended and it printed both single sheets and duplex including pdfs..

I have installed the cups generic pdf printer but it does not show on the screen when I press ^p.

Is this problem solvable or do I revert to Jessie.

Thanks

Alaric

Shadow_7 08-21-2017 12:25 AM

Is the user in the lp and lpadmin groups? otherwise printer installation is a matter of setting up cups (localhost:631) and installing packages plus kernel modules. Most times the kernel stuff is already there.

Otherwise I tend to use a2ps for pdf's and gimp to adjust and print each page plus preview. That way it's not doing 2 pages on 1 page or landscape instead of portrait printing. Plus I can adjust it to B&W / grayscale in the image if I'm out of color ink.

AlaricWood 08-21-2017 12:50 AM

Thanks. I had already checked and corrected 'group' and I am entered under both. I will try localhost:631. Setting up cups is not very easy. Life was much simpler under Jessie. I am aware of a2ps but I don't really see why I should have to go to all that trouble for a simple print job.

Alaric

AlaricWood 08-21-2017 01:11 AM

I have looked at 631. ^p now shows 'pdf'. If I select that and press print I get the usual flash 'Printing completed'. It now shows as a job but it doesn't print.

I note from 631 that the driver for HL-2240 is still 1250.

Alaric

rainydayshirt 08-21-2017 04:44 AM

Printing pdfs
 
Did you install only the generic cupswrapper from Brother? In the past on Debian based systems I have had trouble getting my Brother HL-2270DW setup. Installing the both the LPR and the Cupswrapper files from Brother's website usually did the trick. So, perhaps trying the LPR and Cupswrapper files instead of one of the two generic files will do the trick for you.

Shadow_7 08-21-2017 04:47 AM

I got that on an old hp deskjet printer. Most of the driver stuff was there, except pnm2ppa. Without that it "pretended" to print like a champ.

What are you using to print? Some older things try the old lp/lpr programs to print. So you might just be missing the cups-bsd package which provides those. Although brother seems to have their own driver for that part.

http://www.openprinting.org/printer/...rother-HL-2240

Sometimes you just have to download the ppd file and put it in the appropriate place (/usr/share/ppd/). Although the localhost:631 stuff probably has a selection / properties thing to add the ppd from $HOME/. I don't often setup my printer, or turn it on for that matter.

AlaricWood 08-21-2017 06:47 AM

Thanks. I had installed pnm2ppa. I used to download the Brother debs but they are for 32 bit architecture. Sometimes I can add 386 architecture but there is often a problem with dependencies and they aren't always resolvable. I had installed cups-bsd.

Downloading the ppd file to /usr/share/ppd appears to have worked.

I do appreciate the assistance from the forum. It's one of Debian's best features. I have tried a number of distros. I started with Mandrake but later versions did not support my printer at the time, an HP Laserjet. I looked at a lot of distros' hardware lists and Debian was the only one that seemed to support HP so I switched and have never had any inclination to change.

With Jessie I installed Virtual Box and Windows 2007 in case I needed something not available on Linux but it just sat there and I never used it. On 9 I have not bothered as I haven't found anything I can't do on Debian. Why anyone uses Microsoft I can't imagine. It's not only hideously expensive but also slow and unreliable.

Thanks again.

Regards,

Alaric

AwesomeMachine 08-21-2017 08:36 AM

I keep a Win7 VM. I use it for one thing, to operate a Brother label maker.

Shadow_7 08-21-2017 10:02 AM

I have my printer setup with a 32 bit install on an OLD machine. Basically a print server. But not wifi or IPP, you have to be directly connected to it (static IPs). And cups does job management via email, so cups, cups-browsed, and exim4 (debian) need to be running on the client machine. Plus the hostname of the server with it's static IP in /etc/hosts of the client since I'm not dhcp-ing anything beyond the router that internets. Although I kind of have to do things this way as that OLD machine is the only hardware I have with a parallel port. And it's not beefy enough to bring up the documents to print on the machine that prints anymore. Plus that whole haven't turned it on in 6+ months worth of updates when I just need to print. So as a print server that doesn't get updated, it does it's job nicely.


All times are GMT -5. The time now is 02:55 PM.