LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   printing issues (https://www.linuxquestions.org/questions/linux-newbie-8/printing-issues-282551/)

chemdawg 01-26-2005 02:00 PM

printing issues
 
So far, I have been unsuccessful in configuring my printer to print anything in linux. I have tried everything it says to do in this article under the "configuring printer" section and nothing worked.

linuxtimes.net/modules.php?name=News&file=article&sid=457&page=2

Anyone have ideas as to what i might do?

Here's my stats:

3.0 GHz P4
P5P 800 Motherboard
Epson Stylus CX5400 USB printer
Debian Linux Kernel 2.4.27 (I use KDE 3.3.x)

Matir 01-26-2005 02:05 PM

What printing system are you using? CUPS/LPR/LPRng?

If cups, do cat /etc/cups/printers.conf ; else give us /etc/printcap.

That should be a start. :)

comprookie2000 01-26-2005 03:05 PM

Read this; http://www.linuxprinting.org/show_pr...-Stylus_CX5400
What distro?

chemdawg 01-26-2005 04:07 PM

/etc/cups/printers.conf gives this:

# Printer configuration file for CUPS v1.1.23
# Written by cupsd on Tue Jan 25 14:10:08 2005
<DefaultPrinter epson>
Info
Location
DeviceURI usb://EPSON/Stylus%20CX5400
State Idle
Accepting No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
<Printer>

--------------------
/etc/printcap looks like this:

# /etc/printcap: printer capability database. See printcap(5).
# You can use the filter entries df, tf, cf, gf etc. for
# your own filters. See /etc/filter.ps, /etc/filter.pcl and
# the printcap(5) manual page for further details.

lp|Generic dot-matrix printer entry:\
:lp=/dev/lp0:\
:sd=/var/spool/lpd/lp:\
:af=/var/log/lp-acct:\
:lf=/var/log/lp-errs:\
:pl#66:\
:pw#80:\
:pc#150:\
:mx#0:\
:sh:

# rlp|Remote printer entry:\
# :lp=:\
# :rm=remotehost:\
# :rp=remoteprinter:\
# :sd=/var/spool/lpd/remote:\
# :mx#0:\
# :sh:

----------

thanks for the tip, comprookie. any idea what that page is talking about? i really hoped cups would work, but it doesn't.

comprookie2000 01-26-2005 04:49 PM

Quote:

What distro?
All that means you have cups installed,thats good!

chemdawg 01-26-2005 05:10 PM

no, this page: http://www.linuxprinting.org/show_p...n-Stylus_CX5400

sorry for the confusion. i read this and i really didn't understand it enough to get an idea how to fix things

steve1972 01-28-2005 02:17 PM

orinting issue
 
Just goto http://www.easysw.com/printpro/, use any of the available Epson drivers in C series (perhaps C42 or c60)


All times are GMT -5. The time now is 04:51 AM.