LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Printing (https://www.linuxquestions.org/questions/linux-newbie-8/printing-9167/)

DiBosco 11-24-2001 07:24 PM

Printing
 
I wonder if someone can stop me from chasing my tail.

I installed Mandrake 8.1 a few weeks ago and got my printer working no problem at all. I have an Edimax print server and I remember setting it up after reading a PDF explaining how to do a Unix install and it advised Linux was the same. The Edimax device is one of these little printer servers that plaugs directly into the parallel port and it has its own IP address. So what's the problem I hear you ask. Problem is my original HDD (which was brand new) died and I had to reinstall Linux. then the replacemtn had the same fault (dodgy batch of Western Digitals). This latest HDD is fine.

I've been into control centre and gone to Hardware / Printers and tried to add a printer. I tried a million different things and after I'd done the installation each time it flashed up some dialogue boxes for a time far too short to read said dialogues. Afterwards, no printer was installed.

So I read the Mandrake documentation which went on about CUPS which I tried to run. It seemed I hadn't got it. So I tried installing cups and its associated programs, but RPM reckoned there was summat up with the packages. No problem, ADSL to the rescue and after about a million different downloads I eventually installed cups and all the other programs the RPM asked for.

The documentation boldly claims that by opening a browser and entering http://localhost:631/ you'll be taken to some page that will enable you to administer your printer.

This is a lie! It either says localhost cannot be found or time out trying to connect to localhost.

Localhost definitely exists! If I run smbclient -L locahost it gives me some information about it.

Anyone any ideas? It can't be that hard, because in my oroiganl installation it just worked. Only thing I can think is that on this Mandrake installtion I forgot to install something...

Aussie 11-25-2001 03:57 AM

Try booting from the mandrake cd and selecting "expert" and "upgrade" and adding your printer during the process. Make sure you don't touch the hard drive and you will keep your existing system.


All times are GMT -5. The time now is 02:07 PM.