LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   printer will not print (https://www.linuxquestions.org/questions/linux-newbie-8/printer-will-not-print-588727/)

nancyg 10-01-2007 06:28 PM

printer will not print
 
My Minolta PagePro 1350W laser printer set up fine, and printed pages, days ago. Today it will not print at all, not even a test page. The pages are in the queue, the printer is on, it's connected, it's just not printing. It does need ink, but it's not Printing at all. Not even attempting. Is it because it is reading that it is out of ink?

In all my previous printers, if I ran out of ink, it would just put out a blank page. Then I have to go buy more ink.

But this ink is expensive! I don't want to get more ink if the printer is not going to print.

Why would it print before and not even go through the motions now?

I just spent a lot of money getting new ink for my ink jet printer, Lexmark Z611, which would not print at all with Linux after it was installed.

So I don't want to spend a lot of money I don't have on ink for a printer that is not going to work. I cannot afford a new printer.

But I am a writer. Both of these printers worked before I got into Linux. Help!

pixellany 10-01-2007 06:45 PM

The bad news is that Linux sometimes does strange things with printing. The good news is they are all fixable.

The most common issue I have seen is the print system forgetting where to find a particular printer. I have NOT had this happen recently, which tells me that more modern distros may have solved the issue.

If it is out of ink (toner for a laser), fix that first. The idea is to eliminate variables.

things to try:
Delete everything from the printer queue, turn the printer off and on again.
Delete and re-install the queue in the Printer control panel.
Move the printer to a different port and/or bypass any hubs*

*One zinger I encountered is that my HP laser will not run on anything but USB-2. This means I cannot use it with my USB-1 hub.

Lexmark--I don't know. They are reported to not be good Linux citizens, but I have seen threads where people got them working.

Finally, you might want to look at one of the commercial printing packages--eg Turboprint.

I_like_TUX 10-02-2007 01:32 AM

Some printers do not print when they are out of ink (my printer do that), did you try to print from Windows? (This makes sure it is not the printer but Linux)

You might also try: http://openprinting.org/printer_list.cgi


All times are GMT -5. The time now is 01:39 AM.