-   Linux - Newbie (
-   -   Printer spooler doesn't seem to work (

Match 05-04-2004 04:54 PM

Printer spooler doesn't seem to work
I can print by sending output directly to my printer, but the lpr command can't do it, and I can't print from any programs. I'm using LPRng, and here's some of what I've tried so far (comments and questions are prefaced with '//').

$echo hello world > /tmp/hi
$lpr -V /tmp/hi
LPRng-3.8.26, Kerberos5, Copyright 1988-2003 Patrick Powell, <*****>
Printer lp@myComputer:
// no useful output even though I used the verbose flag

Printer: lp@myComputer (printing disabled)
Queue: no printable jobs in queue
// so the job was never even sent to the queue?

// no output

$lpc status
Printer Printing Spooling Jobs Server Subserver Redirect Status/(Debug)
lp@myComputer disabled enabled 0 none none
// does the "none" under Server and Subserver have any significance?

$lpc lpd
lpd server pid 1997 on myComputer
// lpd is running

$lpc active
Printer: lp@myComputer
lp@myComputer: not implemented yet
// not implemented? How do I implement it then?
// this command is supposed to connect to the server for the printer

Any help would be greatly appreciated.

Match 05-04-2004 10:15 PM

Well, I didn't figure out what was wrong, but I fixed it nevertheless. I uninstalled LPRng and then reinstalled it. Printing works fine now.

All times are GMT -5. The time now is 12:29 PM.