LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-07-2017, 01:43 PM   #1
richieishere
LQ Newbie
 
Registered: Jul 2017
Posts: 7

Rep: Reputation: Disabled
printer problems


im running deb Jessie with KDE for the most part it works grate but im having issues with connecting to my wifi borther hl2170w .. i have already tried to run the "sudo: /home/richiemb/Downloads/Brother/linux-brprinter-installer-2.1.1-1" that i downloaded and extrated from the brother site. it just pops up command not found and im not sure if cups is installed right ether
 
Old 07-07-2017, 01:51 PM   #2
lazydog
Senior Member
 
Registered: Dec 2003
Location: The Key Stone State
Distribution: CentOS Sabayon and now Gentoo
Posts: 1,249
Blog Entries: 3

Rep: Reputation: 194Reputation: 194
Sounds like the program you are trying to run is not executable. Make sure that the installer is able to execute. look at it with 'ls -al' and check that it has x in the line something like:

Code:
-rwxrwxr-x.  1 user1 user1  336 Jun  2 15:42 trimsearch*
 
1 members found this post helpful.
Old 07-07-2017, 01:57 PM   #3
richieishere
LQ Newbie
 
Registered: Jul 2017
Posts: 7

Original Poster
Rep: Reputation: Disabled
think you

it was a permissions issues in the file after check marking the make executable it ran in the term but didnt print the test page via wifi
 
Old 07-07-2017, 02:04 PM   #4
richieishere
LQ Newbie
 
Registered: Jul 2017
Posts: 7

Original Poster
Rep: Reputation: Disabled
here is the stuff that seems to be failing any ideas

Err http://ppa.launchpad.net jessie/main amd64 Packages
404 Not Found
Err http://ppa.launchpad.net jessie/main i386 Packages
404 Not Found
Ign http://ppa.launchpad.net jessie/main Translation-en_US
Ign http://ppa.launchpad.net jessie/main Translation-en
Fetched 21.9 kB in 4s (4,543 B/s)
W: Failed to fetch http://ppa.launchpad.net/mc3man/gstf...amd64/Packages 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/mc3man/gstf...-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.









Restarting cups (via systemctl): cups.service.
lpinfo: cups-deviced failed to execute.
lpinfo: cups-deviced failed to execute.
lpadmin: Bad device-uri scheme "usb".
###############################ls: cannot access /usr/share/ppd/*.ppd: No such file or directory
#
lpinfo: cups-deviced failed to execute.

0 (I): Specify IP address.
1 (A): Auto. (usb://dev/usblp0)

select the number of destination Device URI. ->0

enter IP address ->192.168.1.25
lpadmin -p HL2170W -v socket://192.168.1.25 -E -P /usr/share/cups/model/HL2170W.ppd
lpadmin: Bad device-uri scheme "socket".
Test Print? [y/N] ->y

wait 5s.
echo HL2170W \| lpr -P HL2170W
/home/richiemb/Downloads/Brother/linux-brprinter-installer-2.1.1-1: line 2487: lpr: command not found
Hit Enter/Return key.
 
Old 07-07-2017, 02:12 PM   #5
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917
Regarding the errors with your software sources, can you please paste the output from the following command here:

cat /etc/apt/sources.list
 
1 members found this post helpful.
Old 07-07-2017, 02:21 PM   #6
richieishere
LQ Newbie
 
Registered: Jul 2017
Posts: 7

Original Poster
Rep: Reputation: Disabled
richiemb@richies:~$ cat /etc/apt/sources.list


#

# deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 NETINST Binary-1 20170116-10:57]/ jessie main

# deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 NETINST Binary-1 20170116-10:57]/ jessie main

deb http://ftp.us.debian.org/debian/ jessie main
deb-src http://ftp.us.debian.org/debian/ jessie main

deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main

# jessie-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ jessie-updates main
deb-src http://ftp.us.debian.org/debian/ jessie-updates main

# codec's
deb http://www.deb-multimedia.org jessie main non-free
deb http://download.alephobjects.com/ao/aodeb jessie main
deb http://download.alephobjects.com/ao/aodeb jessie main
richiemb@richies:~$
 
Old 07-07-2017, 02:31 PM   #7
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917Reputation: 2917
That looks fine to my untrained eye. Thanks, Richie.

So where is the "Err http://ppa.launchpad.net jessie/main amd64 Packages
404 Not Found
" coming from? What are you running that generates that error?
 
1 members found this post helpful.
Old 07-07-2017, 02:42 PM   #8
richieishere
LQ Newbie
 
Registered: Jul 2017
Posts: 7

Original Poster
Rep: Reputation: Disabled
tbh im not sure why or where that err is coming from luchpad is a scrit reader but shuldn't be a issue in the printer im trying to figure out this part more then any thing

"" lpinfo: cups-deviced failed to execute.

0 (I): Specify IP address.
1 (A): Auto. (usb://dev/usblp0)

select the number of destination Device URI. ->0

enter IP address ->192.168.1.25
lpadmin -p HL2170W -v socket://192.168.1.25 -E -P /usr/share/cups/model/HL2170W.ppd
lpadmin: Bad device-uri scheme "socket".
Test Print? [y/N] ->y

wait 5s.
echo HL2170W \| lpr -P HL2170W
/home/richiemb/Downloads/Brother/linux-brprinter-installer-2.1.1-1: line 2487: lpr: command not found
Hit Enter/Return key.""""
 
Old 07-07-2017, 02:45 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 21,507

Rep: Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114
On my system the driver is already installed and I would expect cups to automatically find the printer on the network via dnssd.

If you use the cups web page (localhost:631) and select add printer (after login which uses root by default) your printer should be automatically discovered. After you enter the name/location the next page will allow you to select manufacture/model. You should be able to scroll down to the recommended HL-2170W PCL5 driver which works on will on my systems.
 
1 members found this post helpful.
Old 07-07-2017, 02:59 PM   #10
richieishere
LQ Newbie
 
Registered: Jul 2017
Posts: 7

Original Poster
Rep: Reputation: Disabled
thanks i think this might be where the issue might be it shows the home page but the other tabs admin,class,online help,jobs,printers all say notfound when i click on them i dont see a login on the home page eather
 
Old 07-07-2017, 03:08 PM   #11
michaelk
Moderator
 
Registered: Aug 2002
Posts: 21,507

Rep: Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114Reputation: 4114
The login will be a popup windows. If the browser shows page not found for other tabs then the cups server installation is questionable.
 
1 members found this post helpful.
Old 07-07-2017, 04:37 PM   #12
richieishere
LQ Newbie
 
Registered: Jul 2017
Posts: 7

Original Poster
Rep: Reputation: Disabled
thank you all for all your help after a reinstall of the cups and the brother installer with a few setting tweekes a quick restart of the computer and i now can print you guys are grate
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Printer problems, can't find a printer that is attached to a windows network. ahalfapint Linux - Networking 2 04-12-2006 04:29 PM
Problems with HP all-in-one printer Maxorata Linux - General 3 05-21-2005 10:57 AM
Printer Problems trickle Linux - General 7 08-17-2004 05:27 AM
Printer Problems sac_goel Linux - Software 5 05-26-2003 08:07 AM
Printer problems Korshun Linux - Hardware 2 04-03-2002 01:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration