LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-21-2017, 11:12 PM   #1
Thinker8
LQ Newbie
 
Registered: Jun 2017
Posts: 1

Rep: Reputation: Disabled
Printer disabled automatically in CUPS


Hi All,

ZEC label printer was suddenly stopped printing, when i checked the error log found the below error. At this time i saw that the printer went to disabled state, then i enabled the printer by using cupsenable command. Could someone help me how to avoid this issue?, its happening very frequently now.

Code:
I [20/Jun/2017:07:47:49 +0800] [Job 8051] Adding end banner page "none".
I [20/Jun/2017:07:47:49 +0800] [Job 8051] Queued on "14J151701615" by "root".
E [20/Jun/2017:07:59:33 +0800] [Job 8050] Unable to write print data: Broken pipe
E [20/Jun/2017:07:59:33 +0800] PID 25221 (/usr/lib/cups/backend/socket) stopped with status 1!
I [20/Jun/2017:07:59:33 +0800] Hint: Try setting the LogLevel to "debug" to find out more.
I [20/Jun/2017:07:59:33 +0800] [Job 8050] Backend returned status 1 (failed)
I [20/Jun/2017:07:59:33 +0800] Saving printers.conf...
E [20/Jun/2017:08:23:32 +0800] [Job 7956] Unable to write print data: Broken pipe
E [20/Jun/2017:08:23:32 +0800] PID 24198 (/usr/lib/cups/backend/socket) stopped with status 1!
I [20/Jun/2017:08:23:32 +0800] Hint: Try setting the LogLevel to "debug" to find out more.
I [20/Jun/2017:08:23:32 +0800] [Job 7956] Backend returned status 1 (failed)
I [20/Jun/2017:08:23:32 +0800] Saving printers.conf...
 
Old 06-22-2017, 03:37 AM   #2
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
Hi Thinker8.

Welcome to LQ!

Try restarting cups service. If that doesn't work, it could be the printer is going into standby. No real cure for that. It's a bug in the cups program or the print driver. If it is a bug, you should report it.

You could also try stopping the cups service, removing the printer, starting the cups service, and reinstalling the printer. The problem seems to be with cups itself.

Last edited by AwesomeMachine; 06-22-2017 at 03:42 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] cups on current - can't print to cups printer on 14.1 camorri Slackware 14 06-13-2016 03:19 PM
CUPS problem - connecting to local printer as well as CUPS server bobm2011 Linux - Newbie 4 01-11-2010 07:28 AM
Passwords disabled automatically for all accounts Sunheer Linux - Security 8 12-14-2009 10:11 AM
cups to cups printing through network on usb printer checkmate3001 Linux - Server 2 02-16-2009 12:12 PM
Cups printers getting disabled. Why? blizunt7 Linux - Server 6 12-28-2007 03:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration