-   Linux - Newbie (
-   -   preupgrade from limux 12 to 13 - (

rmknox 11-06-2010 12:56 AM

preupgrade from limux 12 to 13 -
I ran preupgrade - it took hours seemed ok
it told me that the boot partition was not large enough but that it would install whatever at boot time provided my internet connection was "hard wired" - not exactly clear what that means but i have a ethernet connection to my dsl modem - which sounded hard wired to me - so i told it to go ahead
at the end it told me to boot
i did, but system hangs with cursor at top left corner
booted again and interrupted the bootloader
see i have the choice to boot the new fedora13 or the last fedora 12
fedora 13 does not boot
fedora 12 does boot

any suggestions? for what it is worth, I also have a fedora 13 distribution cd

frankbell 11-06-2010 07:15 PM

Is the bootloader installed to the MBR? If it is and if the MBR is hosed (it happens--I hosed one yesterday), your best option might be to format the MBR, repartition and format the hard drive (necessary after formatting the MBR in that circumstance), and reinstall from scratch.

If so, first boot to a live CD (Knoppix is great for this) and copy your important data, including any customized configuration files, such as smb.conf and rc.firewall, to a safe place.

If the bootloader is installed to Superblock or to a boot partition, I'm not knowledgeable enough to help you. If the configuration files are accessible with a Live CD boot, you may be able to edit them and fix the problem in a less drastic way.

How to format the MBR under Linux if you don't have a DOS boot disk available. (Note: In the example, the hard drive is hda; if yours is sda, edit the example accordingly.) With a DOS boot, the command is fdisk /mbr.

Please help others help you by posting the exact wording of any error message you receive or a picture of the screen where the failure occurs.

rmknox 11-07-2010 01:06 AM


thanks - turns out I just was too impatient - tried again , waited about 5 min, sytem started. apparently in the interim it was downloading a downloader



All times are GMT -5. The time now is 02:00 AM.