LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   PPPD Deamon Error (https://www.linuxquestions.org/questions/linux-newbie-8/pppd-deamon-error-284/)

fritzlero 11-21-2000 02:35 PM

I'm trying to connect the net using ppp when the dialer reached out the server it prompts me an error:
"The PPPD Deamon died unexpectedly"

then it hangs for a while then it resumes to dialer menu that i cant connect..pls. help me Jeremy :(

CragStar 11-22-2000 06:22 AM

That is exactly the problem that I face. I have managed to get my linmodem:) to work now, after days of configuring, and now I have an error come up after finally being able to dial out! I am not sure why this error comes out, it is not in any of the How-to's which I have read (practically all!). I have thought that it may be to do with the ISP I am trying to dial. It isn't the dialer, I have tried both wvconf and kppp, with the same problem. Another thing is that the modem then locks me out of dialing again, so I have to restart linux to try to get through again. Any thoughts?

Saptech 11-23-2000 07:50 AM

I believe that the error, Modem unexpectingly died message is an ISP problem. I have the same problem using Mandrake Linux 7.1...but now I notice that when I'm using Windoze that the modem pause for about 3 minutes or so then continues but doesn't die out! So it may be an ISP problem.

jeremy 11-23-2000 11:43 AM

Did you comment out 'lock' in /etc/ppp/options?

CragStar 11-23-2000 04:00 PM

I tried lock commented out, but still get pppd dying on me. Saptech, does the apparent loss of connectivity occur when you have just dialed in, or does it happen randomly (i.e whilst you surf?).

Saptech 11-25-2000 06:37 AM

PPPD Deamon Error
 
I posted a reply the other day, but I dont see it. Has the site been having problems lately?

Anyway, mine disconnect after I've been surfing awhile. The longest it went before cutting off was about 40 minutes, mostly about 20 r so min.

I haven't tried commenting out the command Jeremy Suggested yet but I will and see what happens.

Larry James 11-26-2000 12:14 PM

Hi, Snaptech.

I had "posted" a message once. Actually I clicked on Submit Reply. A few hours later I looked at the thread and didn't see my message. I was wondering what had happened. I was about to post again, when I happened to notice a browser window opened with a confiratmion for the post. This might have posible happened to you. You might have missed the sonfirmation step.

Just a thought.

-- L. James

Larry James 11-26-2000 12:26 PM

Saptech. It seems I notice I made a mistake with the click sequence. It seems there isn't a "submt" confirmation. I must have clicked on preview when I meant to click on post.

-- L. James

jeremy 11-26-2000 10:08 PM

Saptech,
This site has had zero problems that I am aware of. Did you get an error message? Did you get taken back to your post, you always should.

torp 12-13-2000 06:25 PM

I have had the same problem.... and i have solved it:))
instead of using the kppp application use netconf and make the modem dail from there, that worked on my comp.
(i have an analog 56K modem)
Remember also : you might have to disable the lock file which is placed in /etc/pppd
So my guess is that this kppp thing is a bit buggy

Well hope that could be some help

Torp

CragStar 12-14-2000 05:49 AM

Torp, you may be a saviour
 
Hi Torp, it seems as if you have found a way round this problem. You said to use netconf, could you please reply and say how exactly you use it to dial out. Dispite My attempts to use kppp, I still have not got anywhere.

Any advice would be much appreciated.

torp 12-15-2000 12:43 PM

If you open a termial and type netconf the prg will open, there you can see and configure your netdevices ppp0 is your modem click that.
Then a menu will open, where you can configure the modem and you can also connect from there.
If it is not installed you can find it on the on the Mandrake cd.
When beeing setup it might bee an idea to install netcfg it is a small app which allows you to disconnect/connect your network devices.
Ps. you have to disable the lock file /etc/pppd/options (i guess) open the file in an editor (e.g gedit) and remowe the word lock (its the only word in the file)
Do this only if you still have problems connecting.
I have to do that with my analog 56K modem, but if you have another type of modem it might not be necessary.

Regards Torp

[Edited by torp on 12-15-2000 at 12:51 PM]

athon_solo 12-19-2000 04:45 PM

Little obvious (to me) thing
 
For those that are having trouble logging in to their ISP, check that your authorization is done using CHAP (this is the most common system).
.
Athon Solo
http://www.teamarena.net

yuniarti 12-21-2000 12:37 AM

are you using ethernet ?? if yes, try first remove the ethernet. kamu sure check /var/log/pppd, if they exist message like this....."not authorize using...", the problem exist on your ethernet. try to modify default gateway to pointing to ppp0.

abndaddy00 01-01-2001 05:57 PM

PPP Linux
 
I just installed Madrake 7.0 last week and have been fighting the same ISP battle.
here is an address with a Document which may prove 2 B very helpful 2 U...

http://axion.physics.ubc.ca/ppp-linux.html

hope this helps.


All times are GMT -5. The time now is 04:54 PM.