-   Linux - Newbie (
-   -   PPP Problems - Pinging and Browsing (

bfloeagle 08-21-2000 04:17 PM

I am having some weird ppp problems.

Basically, I need to connect to the internet 3 times in order to do anything...

I connect one time and nothing happens. I cannot ping or browse anywhere (on my Linux box or any of my Masq'ed machines). I disconnect and reconnect, same problem. I disconnect and then reconnect and everything works! I can ping anywhere and browse to anything.

I have tried this using mulitple ISP's and connecting using more than one of them (connect first to one then second to another). With no luck. After the third time I connect, I can browse using any of my ISP's.

I have tried interchanging the settings and they have not made a difference. I have tried using pap, chap, and basic connect scripts, they made no difference. I have tried using different dialers with no luck (I can only connect with 'ifup ppp0', the other dialers wont connect or stay connected for some odd reason that I cannot figure out...)

I have tried rebooting and everytime I turn on the box I have to do it three times and to make it work. Same for all of the Masq'ed machines. When my Linux box can browse and ping, so can my Masq'ed machines (seems logical...) but not before 3 tries.

'Ifconfig' shows that I am being assigned and IP address each time I connect so something must be working (they are IP addresses that correspond with each of my ISPs and not from my internal network). I dont know if this will help or not but when I do get connected, I sometimes can ping the ip address of my modem and sometimes I cannot. I think I can ping it after I have tried to connect 3 times but not before. I am not sure. If this seems like it could be useful in anyway to help in finding the solution, let me know and I will post what I can do...

Besides that, any idea why this happens? What can I do? What am I missing???


jeremy 08-23-2000 10:00 PM

I have a few questions that I hope will help solve this problem. First are you running routed? If you are turn it off. I know you also have a network card installed. Are you routes setup correctly (ie internet traffic goes out ppp and internal traffic uses eth)? Did you forget the ´defaultroute´ parameter to pppd? This parameter adds a default route into your routing table so that frames to all
other IP addresses will be sent to the PPP device. The PPP software will not replace the default route if you have one
already set when you run pppd. This is done to prevent people from destroying their default route to the ethernet routers by accident. A warning message is written to the system log if the defaultroute parameter is not performed for this reason. Speaking of the system log are there any strange entries?

If you are still having problems do the following. Connect, type ifconfig (copy the output), type route (copy the output) and then post here along with your ppp options file.

bfloeagle 09-03-2000 10:28 AM

Here are the results....
Sorry it took so long to post a response...

I am not running routed and 'defaulteroute' is enabled. I am not sure where to check the system logs. Where should I look? What would be considered a strange entry?

Here are the results from ifconfig and route when I could not browse or ping (first 2 tries):

Link encap:Point-to-Point Protocol
inet addr: P-t-P: Mask:
RX packets:11 errors:0 dropped:0 overruns:0 frame:0
TX packets:11 errors:0 dropped:0 overruns:0 frame:0
collisions:0 txquelen:10

NOTHING! It just tells me that it is the ip routing table and lists the column headings with nothing underneath them. I will just sit there. I have to cancel it so I can get back to the prompt.


Here are the results after the 3rd connect where I could browse and ping:

Link encap:Point-to-Point Protocol
inet addr: P-t-P: Mask:
RX packets:90 errors:0 dropped:0 overruns:0 frame:0
TX packets:90 errors:0 dropped:0 overruns:0 frame:0
collisions:0 txquelen:10

Destination Gateway Genmask Flags Metric Ref Use Iface * UH 0 0 0 eth0 * UH 0 0 0 ppp0 * UH 0 0 0 eth0 * UH 0 0 0 eth1 * U 0 0 0 eth0 * U 0 0 0 eth1 * U 0 0 0 lo
default UG 0 0 0 ppp0

The RX and TX packets kept increasing as I would ping more and more. For all three connections I tried pinging and it only worked the third time. I had to cancel (ctrl-c) the first two times because it would just sit there. I would not even tell me 100% packet loss. I do get a dynamic ip everytime I connect to my ISP. So that one wont be the same next time I try to connect. I sure I didn't have to tell you that but I felt like it anyway. :)

Let me know what you think!

jeremy 09-07-2000 09:04 PM

hmm... Could we have a look at your PPP options file?

bfloeagle 09-26-2000 06:19 PM

Something else...
I want to tell you about something else that I have just found out that is happening before I tell you my ppp options just to see if there is anything else I can do (not that I don't want you to see my ppp options but I want to see if this has anything to do with all my problems).

Same situation with pinging on my internal network, sort of. All my clients can ping my Linux box at any time with no problem. My Linux box cannot ping to any of my clients machines UNTIL I do the three time login thing. Then they can ping back and forth with no problems.

The only other thing that I have noticed is that if I sit on the problem and try to work on it for a half an hour or so, the problem magically fixes itself. I have no idea what I do, it just starts to work. The only things that I can think of that I have done before is to create a new ppp script (via Linuxconf because that is the only way I know how to) to see if that helps and sometimes I let route resolve all of the ip's it needs to.

Does any of this make sense? Could it be related to the problem I am having?

ctdp 09-26-2000 09:41 PM

Are you pinging using IP addresses or the machine name? If you can ping using IP addresses, but have problems pinging using machine names, it is probably a DNS problem.

bfloeagle 09-27-2000 08:58 AM

Only IP Addresses...
I am only using IP addresses to ping back and forth. Any other clues?

This may or may not be useful. The client machines can ping themselves (like they should) when all of this goes on... My Linux box can only ping for the first couple of tries and then when everything magically fixes itself, it can ping IT'S OWN IP address (on either eth0 or eth1) and all the others on my network...

All times are GMT -5. The time now is 06:40 AM.