LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-08-2003, 05:59 AM   #1
tygrmouse
LQ Newbie
 
Registered: Nov 2003
Posts: 6

Rep: Reputation: 0
Angry ppp-go Chatscript expects(CONNECT) and doesn't wait


ok .. Noob btw ... I've been working on this for days, it's one thing after another, and I've been toggling between Windows and Linux to get to the www and then back to my system.

I have my modem working, minicom can dial into my ISP, but I'm trying to set up my PPP and I'm having this problem. I ripped my Windows modem init strings, learned how chat is using the ppp script to talk to it, and have gotten the thing to dial, but now it seems I have a problem with chat.
In my pppscript, the dial portion says:
: OK "ATDT7647647"
: \n \c (this is specific to my modem btw, sends a newline immediately)
: TIMEOUT 120
: CONNECT
But what is happening is, I hear the dialtone for 1/4 of a second and it hangs up, and then my syslog reports:
: expects(CONNECT)
: alarm
Now I've been playing for hours mind you, and I've figured out that TIMEOUT 120 is doing absolutely nothing, it's not waiting for the number to dial and the CONNECT signal, it's throwing an error immediately. I've verified this by changing the script to pause for 20 seconds ...
: OK "ATDT7647647"
: \n \d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\d\c
: CONNECT
What happens here tho, it dials, starts talking, establishes connection speed, and then hangs my entire system and makes my numberlock/slock lights on my keyboard blink :<

I'm pretty sure it's the problem. if I remove a few /d's it gets almost to the data send/recieve portion but hangs up. It literally acts like it's not waiting for anything. I'm using Slackware 9.0 Kernel 2.4.22 (just compiled). If anyone can tell me how to verify/reinstall/fix chat, or an easier solution, wow that'd be great (I'm a noob remember). Or an easier solution than even using a corrupt/fooed chat. Until then, I'll try some of the other stuff in the Howto's, dl some files and stuff, heh.
 
Old 11-08-2003, 10:49 AM   #2
andguent
Member
 
Registered: Sep 2003
Distribution: Woody, SuSE, RH, LAS
Posts: 55

Rep: Reputation: 15
Try looking at http://handsonhowto.com/dodip.html

In there they have a couple ideas for dial up scripts, including:


Code:
The additional parameters to make pppd do dial on demand look like this -- you can put all of this into the file /etc/ppp/options:

demand
idle 60
ipcp-accept-remote
ipcp-accept-local
lock
noauth
defaultroute
user myaccount
remotename myisp
modem 57600 crtscts
connect '/usr/sbin/chat -v -f /etc/ppp/call-isp'
and

Code:
The last line points to a script that tells chat HOW to dial when it's time to dial. It looks like this:

TIMEOUT        5
 ABORT  '\nBUSY\r'
 ABORT '\nNO ANSWER\r'
 ''     \rAT
 'OK-+++\c-OK'  ATH0
 TIMEOUT 40
 OK     ATDT555-1212
 CONNECT        ''
 
Old 11-08-2003, 11:15 AM   #3
tygrmouse
LQ Newbie
 
Registered: Nov 2003
Posts: 6

Original Poster
Rep: Reputation: 0
I got it Har Har Har

So, what I did that made it work, was I took the line: ABORT ERROR right out of the script. The dialing works fine, but it's erroring because it doesn't wait. So, I got an update on my ppp package, compiled/installed it fully, but it still doesn't like to wait for that 'Connect'. I don't know what will happen if I get some wierd error tho. So, it starts trying to talk a little early I'm guessing, because it throws the error and goes on to the rest of ppp-go, starts trying to talk while dialing is still going on. Anyone know if this is dangerous, or a fix or anything? or is it typical?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I've got a OK ppp connection, but cannot connect anywhere! minike Slackware 21 04-15-2005 05:13 PM
Getting reject when trying to connect via ppp. Tarts Slackware 2 11-13-2003 06:40 AM
ppp connect problem linuxBill Linux - Software 8 04-04-2003 09:48 AM
PPP won't Connect CalcAE Linux - Networking 1 06-16-2002 07:18 AM
I have to wait 1:30 after I connect before I can actually do anything online. Manyguns Linux - Newbie 4 07-16-2001 04:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration