LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-16-2003, 11:55 AM   #1
jtsimikas
LQ Newbie
 
Registered: Mar 2003
Location: Tampa FL
Distribution: RedHat 8
Posts: 3

Rep: Reputation: 0
PostFix on RedHat 8


I've been struggling with PostFix for a week now and hope to get some answers from this message board.

* I have my own server w/ dedicated IP address.

* I am running RH8 w/ PostFix preinstalled

* I am using MX Pointing (my registratar www.123cheapdomains.com is actually doing the MX Pointing and also IP Pointing) ps. My web server works fine, but the mail server is having problems.

* I am also using Richard Blum's Postfix book for reference


Questions.
1. Do I need to run DNS BIND on my server? I am trying to avoid this.

2. When I send email (from another server) to my domain, the mail is never recieved. What kind of troubleshooting can I do?

3. Is there a concise tutorial on configuring a mail server w/ PostFix.

4. In the main.cf, there is domainname parameter. If I have multiple
domains how should I set this up?
 
Old 03-16-2003, 12:50 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,576

Rep: Reputation: 191Reputation: 191
1) No, if you've got another DNS the mailserver can ask.
2) Look into the logs. See if it comes. OR: try to send it manually (telnet yourdomain smtp).
 
Old 03-16-2003, 04:40 PM   #3
jtsimikas
LQ Newbie
 
Registered: Mar 2003
Location: Tampa FL
Distribution: RedHat 8
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the reply,

I looked at the log "/var/log/maillog" and noticed
I am getting a "connection refused"

I tried using "telnet <mydomain> smtp"
and got a connection refused.


Actually, I am behind a router.

I went to the NetGear admin page for the router
and set up port forwarding for port 25. I am already
doing the port forwarding for port 80( apache) and 8080 (tomcat)
and the web server has been working fine all along.


I still get a "connection refused" message when I try the
above telnet command even after stopping and starting
postfix.

Any thoughts?
 
Old 03-16-2003, 05:02 PM   #4
jtsimikas
LQ Newbie
 
Registered: Mar 2003
Location: Tampa FL
Distribution: RedHat 8
Posts: 3

Original Poster
Rep: Reputation: 0
More info...

Actually, once I used my LOCAL IP address intead of my domain name, I no longer got the "connection refused" message.


telnet mydomain.com smtp - fails
telent WAN-IP stmp -fails

telnet 192.168.0.3 stmp - works


Actually, this seems to be related to the router.

I can't access my WAN IP address behind the router, I have to use my local network IP.

So perhaps this is an issue I need to bring up with NetGear.

My domain is set up in the /etc/hosts file and points to
192.168.0.3, so I think it is mapped to my local ip anyways?

So actually it should work??
 
Old 03-17-2003, 03:12 PM   #5
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,576

Rep: Reputation: 191Reputation: 191
Your domain should work when it' in /etc/hosts. Check the forwarding again. You should check the router configuration again. Make sure it forwards connection not only from Internet, but also from your local network.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Where can I find the postfix for RedHat 2.4? goonfui_wong Linux - Networking 1 06-23-2005 04:53 AM
Postfix and RedHat 8 evosqueak Linux - Newbie 3 08-13-2004 10:13 AM
postfix at redhat 9 romel Linux - Networking 1 07-23-2004 05:10 AM
postfix on Redhat 9.0 htm Linux - Networking 16 03-26-2004 10:22 PM
Redhat 9 and Postfix Phlef Linux - Networking 4 07-15-2003 03:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration