LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-22-2009, 12:10 PM   #1
p03p
Member
 
Registered: Feb 2009
Posts: 52

Rep: Reputation: 15
pls help me setting up remote desktop


Im trying to remote control my debian os with gnome from my windows xp, i installed vnc4server on debian and tightvnc on windows.

When i start a vnc server it get the name debian:1 but i cant connect to it. I also tried to configure it from
System->preference->remote desktop. and tried to connect trough debian:0 also not working. When i use the ip of de debian computer i can connect. Im not sure what is going on why i only can connect trhough ip.

Can someone help me out?
 
Old 02-22-2009, 12:36 PM   #2
Udi
Member
 
Registered: Jan 2009
Posts: 165

Rep: Reputation: 44
Debian already comes with a VNC server so you don't need to install anything on the Debian side. To enable VNC server on your Debian, go to System->Preferences->Remote Desktop and enable others to view your desktop.

Then, check what your IP address is on Debian (by running /sbin/ifconfig) and try to connect from XP to your Linux with the IP address and not the hostname.

Hope it will work
 
Old 02-22-2009, 12:43 PM   #3
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
i can indeed connect with the ip address

But i didnt had to fill in any ports???
And what do i have to do next to make it accessible from outside my home network??
 
Old 02-22-2009, 02:10 PM   #4
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
im still trying to connect from outside of my network im using this site as a guide but i still cant get it working:
http://www.realvnc.com/support/portforward.html

Im using the vnc server testing page but it always says:
Connecting to port 5900 ... failed: connection timed out

What do i have to do?? I guess something with forwarding a port in my router but not sure.
 
Old 02-22-2009, 02:28 PM   #5
palisetty_suman
Member
 
Registered: Feb 2007
Location: TX, USA
Distribution: fedora
Posts: 191

Rep: Reputation: 33
Thumbs up Hi

I guess you can make use of putty if you know the machine name.
 
Old 02-22-2009, 02:33 PM   #6
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
can i also control my gnome gui with putty?
And cant i connect from outside my home network with putty??

I just tried to connect with putty like to do with tightvnc viewer but its also not working but i think the problem is the port forwarding i think

Last edited by p03p; 02-22-2009 at 02:41 PM.
 
Old 02-22-2009, 02:40 PM   #7
palisetty_suman
Member
 
Registered: Feb 2007
Location: TX, USA
Distribution: fedora
Posts: 191

Rep: Reputation: 33
Thumbs up hi

I don't think so. Putty is actually console mode.
 
Old 02-22-2009, 02:43 PM   #8
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
Quote:
Originally Posted by p03p View Post
can i also control my gnome gui with putty?
And cant i connect from outside my home network with putty??

I just tried to connect with putty like to do with tightvnc viewer but its also not working but i think the problem is the port forwarding i think
yes it is, just forward your ports on your router and it should work
 
Old 02-22-2009, 02:52 PM   #9
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by AceofSpades19 View Post
yes it is, just forward your ports on your router and it should work
I was also guessing it had something to do with my router port forwarding thing.
But i dont know what to configure.

Im using a linksys router under the "application and gaming" i have to fill in:

External Port
Internal Port
Protocol
To IP Address
Enabled

For the ip i have the internal ip my server has
protocal on both
and ofcourse enabled

not sure what to fill in for external and internal port, i tried them both on 5900 but no luck

im also using this site to see my static ip of my router:
http://www.realvnc.com/cgi-bin/nettest.cgi
 
Old 02-22-2009, 04:04 PM   #10
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
1 make sure the service is listening on port 5900
at the original machine type
Code:
telnet 127.0.0.1 5900
2 make sure the port on the router is forwarded to the correct internal ip
from the remote ip type
Code:
telnet xxx.xxx.xxx.xxx 5900

did you restarted the router after you made the changes?
any firewall on the debian box?
any firewall on the windows box?
 
Old 02-22-2009, 04:08 PM   #11
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
i pressed telnet 127.0.0.1 5900 on my debian

But im not sure what u mean with telnet xxx.xxx.xxx.xxx 5900
where do i have to enter this?? and what should the XXX be? The router ip?
 
Old 02-22-2009, 04:12 PM   #12
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Quote:
But im not sure what u mean with telnet xxx.xxx.xxx.xxx 5900
where do i have to enter this?? and what should the XXX be? The router ip?
from the external computer
xxx.xxx.xxx.xxx is the ip of the router
 
Old 02-22-2009, 04:18 PM   #13
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
i entered <router ip> 5900 in my windows dos screen.
But it says <router ip> is not recognized as an internal or external command, operable program or batch file
 
Old 02-22-2009, 04:19 PM   #14
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
telnet xxx.xxx.xxx.xxx 5900

where xxx.xxx.xxx.xxx is the external ip from the router
 
Old 02-22-2009, 04:22 PM   #15
p03p
Member
 
Registered: Feb 2009
Posts: 52

Original Poster
Rep: Reputation: 15
i replaced the xxx with my routers ip but i got that message
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed setting up remote desktop or VNC mlfricke Puppy 3 02-19-2009 10:08 PM
Setting Up a Remote Desktop Server Abnoba12 Linux - Newbie 3 08-03-2006 10:05 AM
accessing remote linux desktop- pls. help arunsri Linux - Networking 1 09-17-2005 02:34 AM
setting up remote desktop watts3000 Linux - Newbie 4 09-25-2004 11:29 AM
Setting up a Remote Desktop Connection over Dial-up? Huezo Linux - Networking 1 01-30-2004 01:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration