-   Linux - Newbie (
-   -   Please help me to fix GRUB (

TroN-0074 06-15-2012 06:36 PM

Please help me to fix GRUB
Hi all.
I would appreciate some advices on how to fix the boot loader on my system

I partitioned my hard drive as follow

sda5-/home-ext3- commom space in the hard drive for all other distros
sda6-/vector linux -Installed first, skiping installation of LILO
sda7-/Antix -Installed second-ext3, allowing GRUB to go to the MBR
sda8-/Arch Linux installed last-Btrfs, Skiping installation of Boot Loader

I dont remember the format for the /vector linux partition but it was one with Journaling and stuff

However I cant get Arch Linux to show on the menu, I thought it was going to be just a matter of typing

on the antix terminal but that didnt do it.
Another thing I tried as root was

find /boot/grub/stage1
root (x,y)
setup (x)
sudo shutdown "now" -r

It didnt work, so at this point I thought to seek help here in the forums instead. I will really appreciate all advices.

Thank you!

EDDY1 06-15-2012 06:54 PM

Mbr is usually starts at sector 1 of hdd or sda1, also where is sda2? Try booting from live-cd & post output of

fdisk -l

TobiSGD 06-15-2012 07:08 PM

Which version of antiX is this? May it be possible that it (or its Grub version) simply doesn't support btrfs?

TroN-0074 06-15-2012 09:55 PM

Something fishy about these boot loaders
Arch is using GRUB2
and AntiX I think is plain GRUB, I am installing AntiX-M11-base-486

I re installed Arch and allowed to re write the MBR hoping that it was going to include the other two distros already installed but when I rebooted it was just the entry for Arch showing on the grub menu.

Then I re installed Antix hoping that when installing grub it was going to include the other two distros but it only included Antix and Vector Linux

Perhaps using Btrfs in /Arch and ext3 in /Antix was not the greatest idea?

Here is the list of my partitions

root@antiX1:/home/demo# fdisk -l

Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d8646

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1            7042        7296    2046976  82  Linux swap / Solaris
/dev/sda2            233        7042    54693292+  5  Extended
/dev/sda3  *          1        233    1864244  83  Linux
Partition 3 does not end on cylinder boundary.
/dev/sda5            233        3394    25390701  83  Linux
/dev/sda6            3394        4610    9767488+  83  Linux
/dev/sda7            4610        5826    9767488+  83  Linux
/dev/sda8            5826        7042    9767488+  83  Linux

Partition table entries are not in disk order

Perhaps that sda2 was the leftover space in the hard drive

I will appreciate it all advices, There is nothing better than spending fathers day weekend installing and configuring Linux :)

syg00 06-15-2012 09:56 PM

Those commands indicate grub classic. It certainly doesn't support btrfs. Create a boot partition (for Arch) - ext3 would be safest.

Our posts "passed in flight".

EDDY1 06-15-2012 10:15 PM

It surprises me that sda1, 2, 3 are reversed, I've only seen that when partitions are removed, & repartitioned.

TroN-0074 06-16-2012 01:35 PM

Yes. The hard drive had a different partition table when I started the installations. Only the Swap partition is from that original set up.

However I re installed Arch in sda8 and reformatted that partition as ext4. GRUB from AntiX still doesn't shows Arch so I think I will have to edit the menu.lst file with an editor from Antix. I have use the editor very few times and frankly I will be more comfortable if somebody suggest me a how to do it. I think the editor in AntiX is nano or leafpad I can't remember, but I will appreciate it guidance.

I have another issue because a thing I did is remove that hard drive from the computer I did the installation and inserted it in another laptop computer which is the one I had intended to use that installation in. The thing is AntiX is now not connecting to the internet, wireless nor hard wired.

I will appreciate all advices. Thank you

EDDY1 06-16-2012 01:46 PM

Since partitions are being moved around you'll need to check /etc/fstab in each os & make adjustments to them.

The thing is AntiX is now not connecting to the internet, wireless nor hard wired.
maybe it's just a matter of different wireless card so you need to install the apropriate module.

TroN-0074 06-18-2012 07:52 PM

O.k so I still need help setting up internet connection. I did a lspci and this is the result

Ethernet controller: Broadcom Corporation NetXtreme BCM5705_2 Gigabit Ethernet (rev 05)

Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

I dont know what information to change in the rc.conf file, actually I am in AntiX and I dont even know if AntiX uses a rc.conf file.
I will appreciate all advices thank you.

TobiSGD 06-18-2012 08:25 PM

rc.conf is Arch only. You also most likely don't need to setup the network, with the Broadcom and Intel devices it is more likely that you lack firmware, firmware-ipw2x00 for the Intel device, firmware-bnx2 for the Broadcom.

TroN-0074 06-21-2012 11:48 AM

I still need help with this threat. I replaced AntiX with SliTaz -4 in partition sda7.
Still have Vector Linux in sda6 and Arch in sda8.
When I installed SliTaz GRUB didn't even created an entry for Vector nor Arch. I think the reason was because these partitions where not mounted at installation time but I don't know if that is an issue. However I am thinking on re install GRUB using the liveCD and making sure sda6 and sda8 are mounted.

If somebody has done this before or if somebody can point out what lines to change in the menu.lst file will be helpful.

I will appreciate all advice helping to solve this issue thank you.

jonnynitro138 06-25-2012 12:43 PM

Not a solution
Hi, hows the system running?
I have a question for you. My system will not recognize linux anymore. I just installed some more ram so I knew that 32bit would not recognize it so I installed windows 7 64 ultimate (I absolutely need windows for school), and then went to install ubuntu 12.04 64 along side it like the last time. My problem is that when I try to install any linux os I get the boot screen but after that I get a black screen with a blinking cursor in the upper left hand corner on the screen. And I put in a new video card msi n460gtx nvidia card, the ram cards are corsair vengeance, and I also put on a corsair water cooled processor unit.
Thank you

TroN-0074 06-25-2012 04:27 PM

I really wanted to use AntiX or any Light Weight distro but I couldnt get to boot the other distros so I installed Debian overraiding sda7 and Debian installed its booter in the boot partition. Automatic added the other two distros to its list.

Thank you for all the responses.

All times are GMT -5. The time now is 06:22 AM.