LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Please help! F'ed my fstab!! Input output error (https://www.linuxquestions.org/questions/linux-newbie-8/please-help-fed-my-fstab-input-output-error-353518/)

wasaabi4784 08-15-2005 02:18 PM

Please help! F'ed my fstab!! Input output error
 
hey guys, I was trying to get my cdrom drive working last night. I opened up my fstab file with vim to check it out , and saw that the line containing the cd drive's information was commented out (?) I removed the "none" in front of the line and gave it a mount-to directory. Did a :wq write quit and mounted the drive. It sat there for about 30 seconds doing something, then completely froze up. Now when I try to boot it gives me an error about the inability to access the fstab file, I tried accessing the file myself with vim, but it wouldn't let me edit it. And I tried e2fsck to check the drive but everything checked out OK

Michael_S 08-15-2005 02:42 PM

I'm no expert, but until some Linux genius comes along I'll see what I can do. :)

1. Can you copy and paste the contents of the /etc/fstab file here for us to look at?

2. What kind of error does it give you when you try to edit the file? Not found? Permission denied?
Are the rest of the files in the /etc/ directory still there? (I don't expect you to know all the files that are supposed to be there. Just make sure the entire directory isn't empty.)

3. (Forgive me for asking an obvious question...) You weren't trying to mount a regular audio CD, were you? Regular audio CDs don't need to be mounted for you to play them. Plus, many audio CDs you buy in stores have copy protection that can 'confuse' your CD drive. That could be what caused the lockup.

wasaabi4784 08-15-2005 02:52 PM

The directory appears to have everything it should in there, more than a page length of files and directories. When I try to do ANYTHING to fstab it tells me "input : output error" . When I vim into fstab it gives me the crap about there being a .fstab.swp file (I tried recovery but it just gave me the broken record again) and instead of opening fstab it creates a new file named fstab (which I can't save because of.... what do you know?... input output error! :) ) However the contents of .fstab.swp are what fstab SHOULD have in it. Unfortunately that was my only computer so I'm at my parent's place posting this, so I don't know the fstab contents by memory. Also, the CD was an old windows game just to see if it was working. I really appreciate the help with this, I'm completely confused.

Michael_S 08-15-2005 03:17 PM

According to this:
http://www.computerhope.com/unix/vim.htm
You may be able to fix the file by typing "vim -r fstab.swp".
Or you may be able to go
"vim fstab" and then inside the (empty) file type ":help recover" and follow the directions to get the file back.

Once (hopefully when) you have the file back, try posting a copy here and we'll see what we can do.

Good luck.


All times are GMT -5. The time now is 02:24 PM.