LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   PLease help cannot enable DMA (https://www.linuxquestions.org/questions/linux-newbie-8/please-help-cannot-enable-dma-298024/)

sendas4 03-05-2005 01:41 PM

PLease help cannot enable DMA
 
Hi im using gentoo with 2.6.10-r6 with the Asuse A7N8X-E Deluxe which using nforce 2.
I compiled the kernel to use the amd and nforce ide. Here is what i get

bash-2.05b# hdparm -i /dev/hda

/dev/hda:

Model=WDC WD800JB-00FMA0, FwRev=13.03G13, SerialNo=WD-WCAJ91445553
Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=58
BuffType=unknown, BuffSize=8192kB, MaxMultSect=16, MultSect=16
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=156301488
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
AdvancedPM=no WriteCache=enabled
Drive conforms to: device does not report version:

* signifies the current active mode


bash-2.05b# hdparm -tT /dev/hda

/dev/hda:
Timing cached reads: 1748 MB in 2.00 seconds = 873.26 MB/sec
Timing buffered disk reads: 12 MB in 3.57 seconds = 3.36 MB/sec


<code>bash-2.05b# hdparm -d 1 /dev/hda

/dev/hda:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)

__J 03-06-2005 06:59 AM

when you compiled your kernel, did you enable "AMD and nvidia IDE chipset support" ?
(it's under device drivers->ATA/ATAPI/MFM/RLL support).

sendas4 03-06-2005 03:58 PM

Ya i did as built in, not as module.

sendas4 03-08-2005 05:34 PM

bump

karl007 03-18-2005 03:50 AM

What das "bump" mean ?

Do you have a Solution for your Problem ??


:thorsten

mysterio 03-19-2005 08:29 AM

Quote:

Originally posted by karl007
What das "bump" mean ?

Do you have a Solution for your Problem ??


:thorsten

Bump just puts it back at the top of the threads, so it has a better chance of being read again.

masonm 03-19-2005 03:27 PM

I'm working on the same problem right now with the 2.6.11-r4 kernel. Am currently recompiling it with a few minor changes. I'll let you know if I get it figured out. Please do likewise.

masonm 03-19-2005 06:41 PM

OK, problem solved. I reconfigured my kernel without the generic IDE support and recompiled. DMA sets fine now.

kushalkoolwal 06-22-2006 06:33 PM

Quote:

Originally Posted by masonm
OK, problem solved. I reconfigured my kernel without the generic IDE support and recompiled. DMA sets fine now.

Hey Dude, I was having exactly the same Problem with DMA not being enabled for AMD and Nvidia Chipset.

Can you post your kernel config if possible?

Thanks

masonm 06-23-2006 08:37 AM

I'm on the road right now and that machine is at home. Like I said, just disable the generic IDE support in the kernel config and it should work for you after you compile the kernel. Did for me anyway.

BTW, I was unable to reply to the email you sent me as you had chosen in your account specifics to not accept emails.

kushalkoolwal 06-23-2006 01:20 PM

Quote:

Originally Posted by masonm
I'm on the road right now and that machine is at home. Like I said, just disable the generic IDE support in the kernel config and it should work for you after you compile the kernel. Did for me anyway.

BTW, I was unable to reply to the email you sent me as you had chosen in your account specifics to not accept emails.

Extremely Sorry Dude, I wasn't aware that by default that thing was turned off. Nways I have gone ahead and enabled it.

Thanks for the support. I will try what you have suggested and will get back if It does not work. HOpe that;s not a problem to you.

Thank you once again.

kushalkoolwal 06-23-2006 04:18 PM

Quote:

Originally Posted by masonm
I'm on the road right now and that machine is at home. Like I said, just disable the generic IDE support in the kernel config and it should work for you after you compile the kernel. Did for me anyway.

BTW, I was unable to reply to the email you sent me as you had chosen in your account specifics to not accept emails.

Well I tried that option and I got a kernel Panic error. Actually there are two similar options:

1.generic/default IDE support.
and
2.default PCI IDE support.


Can you please tell me what were the status of both the options in the kernel config? Acutally I have experimented loads of time with all those IDE options so right now my kernel config is badly screwed, therefore I had asked you to post the Kernel Config of yours.

chaosinmind 04-09-2007 12:36 PM

Gentoo Linux DMA Permission Denied
 
I just removed the one for Generic IDE... I think, and it now seems to be working perfect for me. I also added ide0=dma and ide1=dma to my grub.conf

If you tell me how to copy and paste my kernel config here, I'll post it ASAP.


All times are GMT -5. The time now is 10:46 AM.