LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-07-2009, 11:33 AM   #16
shpenat
Member
 
Registered: Dec 2008
Distribution: LFS
Posts: 95

Rep: Reputation: 21

From your dmesg output I can tell, that you reconnected your USB device several times and you used different devices:

Vendor: HP Model: Officejet 6313 Rev: 1.00

Vendor: T.sonic Model: 610 Rev: 0100

Each time you attach your mass storage (T.sonic) it is asigned to different device (sdb1, sdc1, sdd1). I am little confused by your actions since I am not familiar with CentOS. Here are some questions:

1) Do you have udev? Or what is a reason for running ./MKDEV sdb1
2) What is written in your /etc/fstab? It might help us to understand what you are actually doing.

Just to check how does your computer wok, disconnect your USB storage. Then reconnect it again and run
Code:
dmesg | tail
Look on the output and find to which device your usb was attached (e.g. sdc1). Then switch to root and run
Code:
mount /dev/xxx /media/usb -t vfat
Replace xxx with device shown in your dmesg output and /media/usb with wherever you want to mount your USB device.


To other guys: Don't get so annoyed each time anybody writes urgent, etc. It is rude but replying rudely as well does not help keeping healthy conversation.
 
Old 12-07-2009, 11:41 AM   #17
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by shpenat View Post
To other guys: Don't get so annoyed each time anybody writes urgent, etc. It is rude but replying rudely as well does not help keeping healthy conversation.
I did not see anyone reply rudely......and it has not stopped the substantive discussion.

Posts saying things like "URGENT!!!!" are unfortunately all too common here, and the reaction is getting pretty predictable. Life goes on.....
 
Old 12-07-2009, 01:39 PM   #18
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,830
Blog Entries: 27

Rep: Reputation: 2125Reputation: 2125Reputation: 2125Reputation: 2125Reputation: 2125Reputation: 2125Reputation: 2125Reputation: 2125Reputation: 2125Reputation: 2125Reputation: 2125
Hi,

Quote:
Originally Posted by shpenat View Post
<snip>

To other guys: Don't get so annoyed each time anybody writes urgent, etc. It is rude but replying rudely as well does not help keeping healthy conversation.
I wasn't rude and find your statement to be rude! Most helpers here do aid without rudeness. But some people do need some direction. The mods do keep a good handle on things so I'm not too concerned with statements like yours.
 
Old 12-07-2009, 11:48 PM   #19
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Quote:
Originally Posted by onebuck View Post
Hi,
. To make things cleaner therefore easier to read. You could use a pastebin for really large data/lists.
I nice tool to keep in mind. Thanks a lot.
 
Old 12-08-2009, 01:47 AM   #20
madani
Member
 
Registered: Feb 2009
Posts: 36

Original Poster
Rep: Reputation: 15
Much thanks shpenat (no writing permission in media/usb)

Dear shpenat ,
hi,
Much thanks to you for starting this Thread.
I did what you had recommended and now I can see my usb contents in /media/usb but I (a user) have not permission to write in it ??
May you again direct me ??
and also for making a link on desktop,I R-click on /media/usb but make link is off(inactive).

Bests,and much much thanks
madani
 
Old 12-08-2009, 02:31 AM   #21
shpenat
Member
 
Registered: Dec 2008
Distribution: LFS
Posts: 95

Rep: Reputation: 21
You cannot erite to it because you mounted it as root hence it inherits root permissions. To be able to write to it as user you will have mount it as user. To do so you need to have proper lines in /etc/fstab. Post your /etc/fstab file here, please.
 
Old 12-08-2009, 04:29 AM   #22
madani
Member
 
Registered: Feb 2009
Posts: 36

Original Poster
Rep: Reputation: 15
Dear shpenat'

I copied /etc/fstab contents here as you said:
,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,

/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,

Bests
madani
.......
 
Old 12-08-2009, 05:10 AM   #23
shpenat
Member
 
Registered: Dec 2008
Distribution: LFS
Posts: 95

Rep: Reputation: 21
Add following lines to your /etc/fstab

Code:
/dev/sdb1  /media/usb   vfat   noauto,user  0  0
/dev/sdc1  /media/usb   vfat   noauto,user  0  0
/dev/sdd1  /media/usb   vfat   noauto,user  0  0

And make sure, that /media/usb is writable by user.

This lines will allow you to mount USB manually (e.g. after plugging in your usb you will have to run
Code:
mount /media/usb
to mount it, and
Code:
umount /media/usb
before unplugging it). You can replace /media/usb with whatever directory you want your USB to mount to.


This solution will not completely solve your problem. That right-clicking stuff is probably associated with automounter (package for automatic mounting of devices). I personally have no experiences with this package (I do my mounting manually by running mount). So ask again if you want to e able to mount devices this way.
 
1 members found this post helpful.
Old 12-08-2009, 05:39 AM   #24
madani
Member
 
Registered: Feb 2009
Posts: 36

Original Poster
Rep: Reputation: 15
I could just write in fstab as a root (not as a user).
Still my usb is writing prohibitted for users.
 
Old 12-08-2009, 05:48 AM   #25
shpenat
Member
 
Registered: Dec 2008
Distribution: LFS
Posts: 95

Rep: Reputation: 21
If you still have it mounted as root, you need to unmount it (as root) and mount it again as user.
 
1 members found this post helpful.
Old 12-08-2009, 05:51 AM   #26
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Usually mount command is not accessible to normal user. They do not have permissions on using the command. You can just edit the permissions on the directory where you are mounting the partition. You will have the rights to write to it then.
 
Old 12-08-2009, 07:11 AM   #27
madani
Member
 
Registered: Feb 2009
Posts: 36

Original Poster
Rep: Reputation: 15
I su to root and ran the command: umount /dev/sdd1 /media/usb -t vfat

and then, ...
please see the result:

[Nin@dhcppc0 ~]$ mount /media/usb
mount: /dev/sdb1 is not a valid block device
[Nin@dhcppc0 ~]$

2nd attempt:
[Noushin@dhcppc0 ~]$ mount /dev/sdd1 /media/usb
mount: only root can do that
[Noushin@dhcppc0 ~]$

Bests
...............................

Last edited by madani; 12-08-2009 at 07:13 AM.
 
Old 12-08-2009, 08:01 AM   #28
shpenat
Member
 
Registered: Dec 2008
Distribution: LFS
Posts: 95

Rep: Reputation: 21
My appology, you will have to run
Code:
mount /dev/sdxx
, where sdxx is one of (sdb1, sdc1 sdd1) according to your current assignment. Maybe somebody else can suggest solution.
 
1 members found this post helpful.
Old 12-09-2009, 11:39 PM   #29
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
@madani,

It is saying you can not mount as normal user. And rightly so. You are logged in as normal user and not root. Your shell prompt says that.
Do you have partitions in the removable drive?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: special device /dev/sdb1 does not exist sysbox Linux - Hardware 4 11-11-2013 01:51 AM
mount: special device /dev/cdrom does not exist clau_bolson Linux - Hardware 5 07-12-2007 10:39 AM
mount: /dev/sdb1 is not a valid block device zaltar Linux - General 8 07-13-2005 02:07 AM
mount: special device /dev/cdrom does not exist robrichards Linux - Hardware 20 02-15-2005 02:52 PM
Gentoo: mount: special device /dev/hdg* does not exist mope Linux - Software 4 02-25-2003 12:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration