-   Linux - Newbie (
-   -   pkg-config help (

gexzd 03-18-2004 01:40 AM

pkg-config help
basically it wount find glib 2.4 it will find a different version and use that instead.

i tried the eport command but i figure i aint doing it right

any suggestions



Marc A 03-18-2004 09:14 AM


I mean no harm but i don't really understand what you were trying to do and what doesn't work. To get help you may try to explain what distro you're using, what you need that glib for.
It may be a path problem or a link that doesn't exist.

I wish you'll find someone to help you. Marc A

jbalsiger 05-03-2004 06:15 AM

pkg-config and gimp 2.0.1
I'm trying to compile gimp-2.0.1 on a RH 9 system. I run ./configure but get the following message:

'pkg-config --modversion glib-2.0' returned 2.2.3 but GLIB (2.2.1) was found!

I installed pkg-config earlier but am not sure if I configured it correctly (each "pkg-config help" on the internet has a different suggestion for configuring it...)

I seem to have several versions of glib installed, but how do I find out where they are and how to I get rid of old ones (without breaking dependencies I might not even know about)?

For starters, rpm -q glib returns glib-1.2.10-10. But I also downlodaded and installed (./configure && make && make install) glib-2.2.3.

Can anybody help me sort this out? (I have a feeling once the glib issue is solved, ./configure for gimp 2.0.1 will have similar problems with gtk+).



or1onas 05-03-2004 06:20 AM

Can you use 'locate glib' and see what files are found and where they are?
And one more thing:
First you 'rpm -q glib' and then you installed glib-2.2.3?
I mean, if you 'rpm -q glib' now, will you see both versions or only one?

jbalsiger 05-03-2004 06:35 AM

Thanks for replying!

I just realized that there's a difference between glib and glib 2, so rpm -q glib2 returns glib2-2.2.1-1, which I suppose is the one that the gimp ./configure process finds.

using 'locate glib2' returns the following (among others, I had to shorten it to be able to post this reply):


so nothing about 2.2.3 - I wonder where pkg-config gets that from?

or1onas 05-03-2004 07:15 AM

Can you find a '' file?
It's probably in /usr/lib...
I think that this is the file you need to find...
BTW, you ran './configure' as a simple user or as root?
What is the path you're looking at ($PATH variable)?
ps. I'm a newbie too. I just managed to install Gimp2 yesterday-with no printing support though ;-( - so i know what you're going through :-))

jbalsiger 05-03-2004 07:37 AM

I did find, one in /usr/lib and one in /usr/local/lib

I ran ./configure as simple user (I don't usually become root until 'make install')

I'm not sure whta PATH I'm looking at - just read I needed to configure pkg-config with export something.

And now I found a gimp2 rpm but it finds so many failed dependencies that I won't even bother any longer (just starting with the first one, fontconfig, I find that updating it with the one it needs fails because it needs a file that is part of the version that's already installed - go figure?).

Too bad this is all so user-unfriendly...

or1onas 05-03-2004 08:31 AM

In order to check what folders your path includes, type 'echo $PATH'.
The root's path is much longer than the usual user's, so i guess you should give it a try. I had a similar problem with that.
First 'su', then './configure'.
I guess that '/usr/lib' is already in the root's path. If '/usr/local/lib' is missing,
try: 'export PATH=$PATH:/usr/local/lib'
I'll be waiting for more info...

jbalsiger 05-03-2004 08:41 AM


I must have lost the pkg-config directory along the way. How to get it back?

I did export the usr/lib and usr/local/lib directories to the PATH, as you suggested (they were not in the root's PATH)

Then I became root and ran ./configure - now I get :

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.2.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: Test for GLIB failed. See the file 'INSTALL' for help.

thanks for hanging in there!

or1onas 05-03-2004 09:40 AM

Just a sec.
If you first made 'export blah blah blah..'
and then su'd, then u probably made the change for no reason...
When you switch to root, you get HIS $PATH variable, which is different from the simple user's.
So, first su, then 'export PATH=$PATH:/usr/local/lib'.
You'll make it, don't worry ;-)

jbalsiger 05-03-2004 10:43 AM

done that. ran ./configure on gimp again, now it hangs with the message that gtk+ is not found. updating gtk+ has now gotten me into all kinds of new pandora's boxes, the latest being that compiling gtk+ hangs because it does not find 'sufficient FreeType'...

or1onas 05-03-2004 10:48 AM

I guess you should try to find some distro-specific rpm's for GTK+..
I'll be waiting...

jbalsiger 05-03-2004 11:10 AM

Can't find any RH9-specific GTK+. Running ./configure on GTK+-2.4 ends with:

checking For sufficiently new FreeType (at least 2.0.1)... no
configure: error: pangoxft Pango backend found but did not find freetype libraries

or1onas 05-03-2004 11:14 AM

Now you know the drill...
Find the freetype libs...
Check or
Install them and retry...
It took me 7 hours to make my first compilation (that was last week with SuperKaramba..), but now i feel better and more confident....
Give it a try! It's fun (i guess :-) )

jbalsiger 05-03-2004 11:27 AM

Thanks ;-) I do know the drill, have already spent a good 20 hours trying to compile KDE 3.2, all to no avail. One problem I keep encoungtering is that different rpm packages instlal there fiels in different files, so that sooner or later an update looks for its base files in the wrong place. I can't tell you how many times I've encountered xyz-1.2 needs (installed) xyz-1.1

I give it a try when I have time, but mostly I give up. I run linux on a custom-made laptop, that has kernel-specific drivers, otherwise I'd just say to hell, I'll change or upgrade to a distro that has KDE3.2 and gimp2, etc. already precompiled. But that wouldn't be the pint of linux either, would it?

Thanks for your help and encouragemenet anyways!

All times are GMT -5. The time now is 03:31 PM.