LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-23-2004, 11:49 PM   #1
everbloom
LQ Newbie
 
Registered: Mar 2004
Location: Australia
Distribution: Fedora Core 3
Posts: 20

Rep: Reputation: 0
pkg-config 'not there' on RedHat 9


I've got Red Hat 9 and I'm running Gnome. I tried to install the new 2.0.0 release of GIMP from source, using the configure file. I got these errors

***A new enough version of pkg-config was not found
***See (site)freedesktop.org/software/pkgconfig
configure: error: Test for GLIB failed. See file 'INSTALL' for help

So, I looked at the INSTALL file, and it didn't say anything about GLIB, but it did say that it required some 3rd-party libraries, so I presume it is one of them. Not really a big issue (I hope).

My main problem is this. I went to the site and downloaded the newest version of pkg-config and ran its configure file. I got no errors there. (Version 0.15.0). Then I tried re-running GIMP's configure and got the same errors again. No I DO have pkg-config, and I've had this problem when trying to install other programs. Could someone please tell me why it can't see pkg-config and anything I can do to fix this problem?

(if someone has a link to where I can download GLIB that would be handy too)

Last edited by everbloom; 03-23-2004 at 11:52 PM.
 
Old 03-24-2004, 06:32 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
what do you get if you run "pkg-config --version" ? it doesn't say it can't find it, it says it's too old, so try an upgrade if possible.
 
Old 03-25-2004, 12:39 AM   #3
everbloom
LQ Newbie
 
Registered: Mar 2004
Location: Australia
Distribution: Fedora Core 3
Posts: 20

Original Poster
Rep: Reputation: 0
Okay. I updated to pkg-config version 0.15.0, and now I don't get that error.

Now I get

***Could not run GLIB test program, checking why...
***The test program failed to compile or link. See the file config.log for the exact error that occured.
***This usual means that GLIB is incorrectly installed.
configure: error: Test for GLIB failed. See the file 'INSTALL' for help

and I am compleatly lost.

I probably look realy stupid... oh well... I'm just starting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pkg-config sinXposed Linux - Software 12 10-30-2008 05:48 AM
pkg-config supersucker Linux - Software 3 09-07-2004 09:45 AM
pkg-config help gexzd Linux - Newbie 14 05-03-2004 10:27 AM
pkg-config TraCe66 Linux - Newbie 1 07-01-2003 02:56 PM
pkg-config Keebler Linux - Software 2 04-30-2003 02:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration