LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-02-2004, 01:54 AM   #1
gruessle
Member
 
Registered: Dec 2003
Location: USA
Distribution: Debian
Posts: 40

Rep: Reputation: 15
Question phpmyadmin?


I got Apache, php, mysql working on a Debian installation
and I have phpmyadmin installed
The only thing which is not working is
h t t p : / / localhost / phpmyadmin

Someone told me that I need to create a symlink to it in /var/www
I tried that and received an error saying that phpmyadmin already exists.
Can someone show me what the command needs to look like or how I can get this to work?

Here is a link on how to setup Debian which was very helpful
projektfarm.com/en/support/debian_setup/
 
Old 01-02-2004, 02:14 AM   #2
nephilim
Member
 
Registered: Aug 2003
Location: Belgium
Distribution: Debian (server), Kubuntu (desktop)
Posts: 248

Rep: Reputation: 30
What do you see when you go to http://localhost? Isn't there a link to phpmyadmin?
 
Old 01-02-2004, 03:31 AM   #3
Technoslave
Member
 
Registered: Dec 2003
Location: Northern VA
Posts: 493

Rep: Reputation: 30
Sounds to me like you need to setup an alias in your httpd.conf

Yes, you can possibly link it from your home directory, but that's not recommended. Nor should you just have phpmyadmin open for everyone to see.

So, you'll want to edit your httpd.conf file, you'll want to search for Alias ( just like that ) that will take you to your aliases section, where you'll want to create something like:

Alias /myadmin "/place/where/phpmyadmin/lives"

Then you'll want to look in to restricting access to there. Once you get the Alias stuff taken care of...if you want to lock it down some more...then reply, I'll go in to doing that with you.
 
Old 01-05-2004, 03:44 AM   #4
gruessle
Member
 
Registered: Dec 2003
Location: USA
Distribution: Debian
Posts: 40

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Technoslave
Sounds to me like you need to setup an alias in your httpd.conf

Yes, you can possibly link it from your home directory, but that's not recommended. Nor should you just have phpmyadmin open for everyone to see.

So, you'll want to edit your httpd.conf file, you'll want to search for Alias ( just like that ) that will take you to your aliases section, where you'll want to create something like:

Alias /myadmin "/place/where/phpmyadmin/lives"

Then you'll want to look in to restricting access to there. Once you get the Alias stuff taken care of...if you want to lock it down some more...then reply, I'll go in to doing that with you.


I got it working - it took so long because I made a misstake and had to reinstall everything.

Thank you for your help and if your offer still stands I would like to 'look it down some more'

This is what it look like right now:
Code:
Alias /myadmin/ /usr/share/phpmyadmin/

<Directory /usr/share/phpmyadmin>
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>
 
Old 01-09-2004, 12:09 AM   #5
Technoslave
Member
 
Registered: Dec 2003
Location: Northern VA
Posts: 493

Rep: Reputation: 30
Ok, to lock down, what you'll want to to look at your httpd.conf file a little bit.

Under your Alias section and your ScriptAlias ( that's under Alias ), you'll see something along the lines of:

<Directory "/usr/local/apache2/cgi-bin">

Well, under the </Directory> of the above line, I have something like this:

<Directory "/place/where/phpMyAdmin">
AuthType Basic
AuthUserFile /place/where/phpMyAdmin/.htpasswd
AuthName "MyAdmin Stuff"
Require valid-user
</Directory>

Then, in your phpMyAdmin directory, you'll have two files. The first one I believe you have to create yourself.

.htaccess

And it will have something like this:

AuthName "MyAdmin Stuff"
AuthType Basic
AuthUserFile /place/where/phpMyAdmin/.htpasswd

require valid-user

Then what you'll want to do is execute the command htpasswd ( usually located inside the bin dir in your apache dir )

And you'll want to type it out like:

htpasswd -c /place/where/phpMyAdmin/.htpasswd username

That will create the .htpasswd file for you. Restart apache and give it a try...remember, if something comes up, look in your error logs to see if you can figure it out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Phpmyadmin Pb, Help Please !!! photoworks Linux - Networking 7 06-12-2005 06:06 PM
can not use phpmyadmin haola Debian 1 06-09-2005 10:42 PM
phpmyadmin help dickohead Programming 2 05-01-2005 03:29 AM
phpMyAdmin Help Ascis Linux - Newbie 2 08-15-2004 06:00 AM
phpmyadmin seanlinux Linux - Software 1 12-06-2003 04:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration